Opened 6 years ago

Closed 4 years ago

#8537 closed Bug (fixed)

Strange result when merging cells in tables

Reported by: Henrik Helmø Larsen Owned by:
Priority: Normal Milestone:
Component: Core : Tables Version: 3.1
Keywords: Cc:

Description

I get a strange result i Chrome when making a 3x3 table with first row and first column set as header and then merging the middle cell of the first row down!

See attached screenshot from your http://ckeditor.com/demo page

I have entered the values a, b, c, ... , i ind the cells to start with (a, b and c being the first row, d, e and f being the values of the second row, etc). As expected the value b and e are then merged into the same cell - but the structure of the table now looks funny. I guess this is because the first row is a header row and the second row (middle cell) is not...?

Attachments (3)

table problem.PNG (92.8 KB) - added by Henrik Helmø Larsen 6 years ago.
Webkit.png (15.4 KB) - added by Jakub Ś 6 years ago.
others.png (15.4 KB) - added by Jakub Ś 6 years ago.

Download all attachments as: .zip

Change History (6)

Changed 6 years ago by Henrik Helmø Larsen

Attachment: table problem.PNG added

comment:1 Changed 6 years ago by Henrik Helmø Larsen

Component: GeneralCore : Tables

comment:2 Changed 6 years ago by Jakub Ś

Status: newconfirmed
Version: 3.6.23.1

Issue has been reproducible in all browsers from CKEditor 3.1.

To reproduce:

  1. insert table 3x3 with both headers.
  2. fill it in with values from 1 to 9
  3. Go to cell 2, right-click -> Cell -> Merge Down

Result: Cell 2 will be joined with cell 5. Additionally cell 4 and 6 will be mowed left. There is a slight difference between how cells are rendered in Webkit and other browsers (See Webkit.png and others.png).

Changed 6 years ago by Jakub Ś

Attachment: Webkit.png added

Changed 6 years ago by Jakub Ś

Attachment: others.png added

comment:3 Changed 4 years ago by Jakub Ś

Resolution: fixed
Status: confirmedclosed

Problem is no longer reproducible in latest CKEditor 4.3.2

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy