Opened 7 years ago

Last modified 7 years ago

#8551 confirmed Bug

Browser hangs with with certain combination html (meta/link) and 'enterMode'

Reported by: Pieter Fibbe Owned by:
Priority: Normal Milestone:
Component: UI : Source View Version: 3.5.3
Keywords: Cc:

Description

On the demo page initialize a new ckeditor with the following enter-mode:

CKEDITOR.config.enterMode = CKEDITOR.ENTER_BR; CKEDITOR.appendTo('demoInside', { height: 300 });

Go to 'source' view and type:

<table>
 <tbody>
   <tr>
      <td>
	  <table>
	    <tr>
	      <td>
	         <meta>
		 <link>
	      </td>
	    </tr>
	  </table>
        </td>
      </tr>
    </tbody>
</table>

Click again on 'source' mode to go back to normal mode (WYSIWYG). The browser now hangs.

It only seems to happen with a table nested in another table in combination with 2 'link' or 'meta' tags or a combination.

The problem seems to occur in fragment.js in the 'while (1)' loop.

Although it might not be correct html to have 'meta' or 'link' tags in the body part, a lot of our clients are using reports/templates with this kind of code for certain (historical) reasons and now suddenly run into this problem since we have switched from FCKEDITOR to CKEDITOR. Please make it backwards compatible.

Change History (2)

comment:1 Changed 7 years ago by Jakub Ś

Status: newconfirmed
Version: 3.6.23.5.3

Reproducible from CKEditor 3.5.3 rev [6629]

comment:2 Changed 7 years ago by Jakub Ś

Other tickets where this revision is mentioned: #8189, #9186, #8481, #9006.

Last edited 7 years ago by Jakub Ś (previous) (diff)
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy