Opened 6 years ago

Closed 3 years ago

#9160 closed Bug (fixed)

r7387 breaks editor in Chrome Win7

Reported by: Julian Picht Owned by:
Priority: Normal Milestone: CKEditor 4.5.2
Component: General Version: 3.6.3
Keywords: Webkit Cc:

Description

Using Chrome 19.0.1084.56 on Win7 [7387] (fix for #7360) "7360_2.patch​" breaks the editor.

When leaving the tab with the editor and returning to that tab, the editor just vanishes, because mainElement.getSize returns zero.

Reverse apply of "7360_2.patch​" fixes this for me.

My config:

var ckEditorConfig = {
    removePlugins: 'elementspath,maximize,resize',
    extraPlugins : 'autogrow',
    autoGrow_bottomSpace: 20,
    autoGrow_minHeight: 10,
    resize_enabled: false,
    autoUpdateElement: true,
    sharedSpaces : {
        top : 'topSpace',
        bottom : 'bottomSpace'
    },
    toolbarCanCollapse: false,
    contentsCss: '/css/email_editor_content.css'
};

The editor is instantiated with jQuery adapter:

    $someElement.find('textarea').ckeditor(ckEditorConfig);

Attachments (3)

9160_sample.html (1.3 KB) - added by Invictus 6 years ago.
9160.png (99.2 KB) - added by Invictus 6 years ago.
9160_sample2.html (1.8 KB) - added by Invictus 6 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 6 years ago by Jakub Ś

Status: newpending
Version: 3.6.5 (SVN - trunk)

I couldn't reproduce it. I have tried to use the above code but CKEditor did not vanish.

Could you provide exact steps to reproduce this problem, provide perhaps the reduced and working test-case file showing the problem?

comment:2 Changed 6 years ago by Invictus

[7387] creates new listener for window "resize" event each time iframe is recreated and they are not cleaned up properly. For example if you call editor.setData() 10 times you will end up with 10 extra listeners for window "resize" event. And you will get a batch of exceptions if you switch to source mode and then try to resize browser window.

comment:3 Changed 6 years ago by Jakub Ś

This issue has been fixed one more time in ticket: #9069. If you have problems with popups you should update to the latest CKEditor 3.6.4 where this issue was finally resolved.


For example if you call editor.setData() 10 times you will end up with 10 extra listeners for window "resize" event. And you will get a batch of exceptions if you switch to source mode and then try to resize browser window.

Could I ask you to provide reduced test case file (working) showing this problem in code? Sample file (perhaps modified CKEditor sample) that can be put in ckeditor/_samples/ folder.

Changed 6 years ago by Invictus

Attachment: 9160_sample.html added

comment:4 in reply to:  3 Changed 6 years ago by Invictus

Uploaded.

Replying to j.swiderski:

Could I ask you to provide reduced test case file (working) showing this problem in code? Sample file (perhaps modified CKEditor sample) that can be put in ckeditor/_samples/ folder.

Last edited 6 years ago by Invictus (previous) (diff)

comment:5 Changed 6 years ago by Jakub Ś

Sorry but I didn't get any bugs.

I have put this file in samples folder, pushed run test few times and resized browser window but browsers Console showed no exceptions.

Sorry but in which browser are you getting this and what exactly I should be looking at?

Changed 6 years ago by Invictus

Attachment: 9160.png added

comment:6 Changed 6 years ago by Invictus

Chrome 21, CKEditor 3.6.4
See screenshot in attachment

Last edited 6 years ago by Invictus (previous) (diff)

comment:7 Changed 6 years ago by Invictus

Another problem related to 7360_2.patch: if we resize browser window when editor is not visible, editors text would not be displayed when we show editor again (see sample 2).

Last edited 6 years ago by Invictus (previous) (diff)

Changed 6 years ago by Invictus

Attachment: 9160_sample2.html added

comment:8 Changed 6 years ago by Jakub Ś

Keywords: Webkit added
Status: pendingconfirmed
Version: 3.6.3

Both problems have been reproducible in Webkit from CKEditor 3.6.3 rev. [7387].

Java Script error for first problem:
Message: Uncaught TypeError: Cannot call method 'hide' of null
Line: 559
URI: /ckeditor/_source/plugins/wysiwygarea/plugin.js

@Invictus it is true that both of these errors didn't occur before rev. [7387] and both should be fixed but could you tell me why would you want to resize editor after it was hidden? Is there any real use case behind it?

comment:9 Changed 6 years ago by Invictus

I do not resize the editor myself. It happens when there is an editor inside tab panel or collapsible region and user resizes browser window and then navigates to the editor itself.

comment:10 Changed 6 years ago by Jakub Ś

Another issue caused by this revision is #9715.

comment:11 Changed 3 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.5.2
Resolution: fixed
Status: confirmedclosed

Fixed by #11616.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy