Opened 7 years ago

Closed 7 years ago

#9175 closed Bug (fixed)

IE8-9 - Selecting everything via mouse drag and hitting backspace causes browser to go back

Reported by: mgrove Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.6.5
Component: General Version: 3.6.3
Keywords: IE8 IE9 Cc: satya_minnekanti@…, brooks@…

Description

Steps to Reproduce

  1. Place some text in the editor field (make sure it is the only thing in the editor field)
  2. Highlight all of the text in the editor by clicking and dragging the mouse from the right side to the left side of the screen.
  3. Press backspace

Expected Result

  1. Deletes all of the highlighted text

Actual Result

  1. IE9 makes the browser go back to the previously visited page

Note Video of the issue being reproduced: http://screencast.com/t/KbxCpzByVNtg

Attachments (4)

replacebycode4.html (2.8 KB) - added by Jakub Ś 7 years ago.
IE.png (8.9 KB) - added by Jakub Ś 7 years ago.
9175.patch (3.8 KB) - added by Garry Yao 7 years ago.
9175_2.patch (4.0 KB) - added by Garry Yao 7 years ago.

Download all attachments as: .zip

Change History (18)

comment:1 Changed 7 years ago by Jakub Ś

Keywords: IE8 IE9 added
Status: newconfirmed
Version: 3.6.3

Issue has been reproducible from CKEditor 3.6.3 rev. [7374] and only in IE8 and IE9.

It looks like when you start selection below text, finish it outside of editor and press Backspace it acts like Back button.

To reproduce:

  1. Copy attached file to _samples folder and open it in IE8 or IE9
  2. Make a selection from right to left and make sure that you start below the sample text and let go the mouse button when you are outside of editor.
  3. Press Backspace button.

comment:2 Changed 7 years ago by Jakub Ś

Next to #9097 this is another issue caused by this revision.

Please also note that fix presented in [7374] is not complete - please see #8919

Changed 7 years ago by Jakub Ś

Attachment: replacebycode4.html added

comment:3 Changed 7 years ago by Jakub Ś

There are also other tickets caused by revision [7374] - #9329 and #8919.

comment:4 Changed 7 years ago by Satya Minnekanti

Cc: satya_minnekanti@… added

adding myself to cc

comment:5 Changed 7 years ago by Jakub Ś

Summary: IE9 - Selecting everything via mouse drag and hitting backspace causes browser to go backIE8-9 - Selecting everything via mouse drag and hitting backspace causes browser to go back

Another use case:

  1. Start selection below text, finish it outside of editor and press bold button or (See attached image IE.png) Start selection in white area between grey border and | ^ This is ... and finish it at the end of This^ for example.
  2. Click Bold icon or apply background-color.

Result: Cursor moves back to beginning of text.

Changed 7 years ago by Jakub Ś

Attachment: IE.png added

comment:6 Changed 7 years ago by Jakub Ś

#9356 was marked as duplicate.

comment:7 Changed 7 years ago by Brooks

Cc: brooks@… added

Adding myself to cc

comment:8 Changed 7 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.6.5

Changed 7 years ago by Garry Yao

Attachment: 9175.patch added

comment:9 Changed 7 years ago by Garry Yao

Owner: set to Garry Yao
Status: confirmedreview

In additional to the ticket issue, the patch also addressed the following bug in IE7:

  1. Start a text selection, outside of body, from left to right;
  2. Move mouse back to the start point of the above selection, to it's left;
  • Actual: The text selection is discontinued because of that.

comment:10 Changed 7 years ago by Frederico Caldeira Knabben

The patch made the selection even harder now, as the user cannot risk crossing the editing area boundaries:

  1. Start the selection af the bottom right and move to the top left a bit to start selecting.
  1. While selecting, move outside the editor to the top.
  1. Return to the editor to continue the selection.

It will not work (IE8 at least). The selection will be frozen at the moment we leave the editor on step 2.

comment:11 Changed 7 years ago by Frederico Caldeira Knabben

Status: reviewreview_failed

Changed 7 years ago by Garry Yao

Attachment: 9175_2.patch added

comment:12 Changed 7 years ago by Garry Yao

Status: review_failedreview

comment:13 Changed 7 years ago by Frederico Caldeira Knabben

Status: reviewreview_passed

comment:14 Changed 7 years ago by Garry Yao

Resolution: fixed
Status: review_passedclosed

Fixed with [7621].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy