Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#9356 closed Bug (duplicate)

IE9 Line Break with Space Preventing Bold, Italics, and Underline

Reported by: Brooks Owned by:
Priority: Normal Milestone:
Component: General Version: 3.6.4
Keywords: Cc:

Description

This issue only shows up in IE9. To duplicate the issue

  • Go to http://ckeditor.com/demo
  • Clear out everything in the editor
  • In a Word Doc type a sentence, then press return, space, return.
  • Then write another sentence.
  • Continue to do this for a few lines so you have the pattern (sentence, empty line with one space, sentence, empty line with one space, sentence) so on.
  • Paste this into the editor as plain text, but copying to clipboard, then clicking the Paste as Text button.
  • Then highlight the first few words of the second sentence and try to bold, italics, or underline. You will notice it won't.

This caused by that empty line with a single space within it. A very specific and odd issue. If you paste it as Word format it's fine, only IE9 and only if you paste it as text, with a empty line with a space above the word or line you wish to bold.

Attachments (2)

Screen Shot 2012-09-19 at 4.28.51 PM.png (36.6 KB) - added by Brooks 7 years ago.
Screen Shot 2012-09-19 at 4.27.56 PM.png (52.0 KB) - added by Brooks 7 years ago.

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by Brooks

Changed 7 years ago by Brooks

comment:1 Changed 7 years ago by Jakub Ś

Keywords: IE9 Breaks Bold Empty Return with Single Space removed
Resolution: duplicate
Status: newclosed

DUP of #9175.

After some testing I've came to the conclusion that this bug report is in fact duplicate of #9175. Please see comment 5 for good way to reproduce this problem - http://dev.ckeditor.com/ticket/9175#comment:5.

It seems that it does not matter whether you paste plain text or formatted with Word. If you start selection between editor border and text or start selection below text and finish behind editor then styles won't be applied.

@helpinspire please check your TC one more time and if you think that this is not duplicate of #9175 please provide more details showing how to reproduce this issue.
Especially interesting part is where exactly you start selection (screen shot may be needed).

comment:2 Changed 7 years ago by Brooks

I agree, this is a duplicate issue discussed in #9175. Close out this ticket and I will subscribe to the other ticket to hear about a fix.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy