Opened 10 years ago

Closed 10 years ago

#9257 closed Bug (duplicate)

[Safari 5] Pasted data are wrapped with styling <div>

Reported by: Piotrek Koszuliński Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0
Keywords: Cc:

Description

  1. Open any replacebyclass sample.
  2. Delete everything.
  3. Write one paragraph of text.
  4. Select all and copy.
  5. Press ctrl+v, enter few times.
  6. Switch to source mode.

Editor content:

<p>test.</p>

<div style="font-family: Arial, Verdana, sans-serif; font-size: 12px; color: rgb(34, 34, 34); background-color: rgb(255, 255, 255); ">
<p>test.</p>

<div style="font-family: Arial, Verdana, sans-serif; font-size: 12px; color: rgb(34, 34, 34); background-color: rgb(255, 255, 255); ">
<p>test.</p>

<div style="font-family: Arial, Verdana, sans-serif; font-size: 12px; color: rgb(34, 34, 34); background-color: rgb(255, 255, 255); ">
<p>test.</p>

<div style="font-family: Arial, Verdana, sans-serif; font-size: 12px; color: rgb(34, 34, 34); background-color: rgb(255, 255, 255); ">
<p>test.</p>
</div>
</div>
</div>
</div>

This issue is reproducible on v3 as well.

Chrome wraps pasted content in styling span only when "styling" contexts of copied content origin and paste place differ. It looks like Safari unfortunately always does this.

Change History (5)

comment:1 Changed 10 years ago by Garry Yao

Milestone: CKEditor 4.0

We'll be very hard to handle this right now.

comment:2 Changed 10 years ago by lmeurs

I cannot reproduce this in CKEditor 4.0 DEV (revision 20c9d6f) and Chrome v22...

Last edited 10 years ago by lmeurs (previous) (diff)

comment:3 Changed 10 years ago by Piotrek Koszuliński

Summary: [Safari] Pasted data are wrapped with styling <div>[Safari 5] Pasted data are wrapped with styling <div>

Because that's Safari's 5 problem. I believe that it was occurring in old version of Chrome, but was fixed in Webkit's version released between Safari 5 and Safari 6 (so it's also fixed in Safari 6).

comment:4 Changed 10 years ago by Jakub Ś

This ticket duplicates #7146.

Instead of creating new ticket for v4, new comment should be added to #7146.
Other tickets that concern pasting in Webkit are: #6131 and #6436.

comment:5 Changed 10 years ago by Jakub Ś

Resolution: duplicate
Status: newclosed

DUP od #7146

@Reinmar I have moved your comment to that ticket.

Note: See TracTickets for help on using tickets.
© 2003 – 2022, CKSource sp. z o.o. sp.k. All rights reserved. | Terms of use | Privacy policy