Opened 7 years ago

Closed 7 years ago

#9258 closed Bug (fixed)

Incorrect handling of multiple font-sizes chosen at the same time

Reported by: Piotrek Koszuliński Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 4.0
Component: General Version: 4.0
Keywords: Cc:

Description

Tested on Firefox and Chrome.

  1. Open any sample.
  2. Place caret in the editor.
  3. Choose font size 20.
  4. Type few letters.
  5. Choose font size 28.
  6. Type few letters.
  7. Choose font size 28 again so it will be removed.
  8. Type few letters.
  9. Typed letters has font size 20, but 28 is still highlighted.
  10. Open combo again - 28 is highlighted.
  11. Click 20.
  12. Everything is ok now - size in combo and for typed text is back to default.

Change History (3)

comment:1 Changed 7 years ago by Garry Yao

Owner: set to Garry Yao
Status: newreview

It's a regression, caused by our immediate selection change event in v4, but the culprit is instead inside of list block impl.

comment:2 Changed 7 years ago by Frederico Caldeira Knabben

Status: reviewreview_passed

The list block implementation is not wrong. It is just considering a feature which we're not using on any of our plugins, where non-multiselect lists don't have the toggle effect (like select boxes).

But considering that we're not using that feature, we can accept this change, because all our combos act like selection boxes with toggle behavior. If we'll have troubles with this, we'll be able to revert this and try another approach.

comment:3 Changed 7 years ago by Garry Yao

Resolution: fixed
Status: review_passedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy