Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#9315 closed Bug (fixed)

Editor is removed when deleting all content and editor (div) is inside table

Reported by: Mike Burgh Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 4.0
Component: Core : Editable Version: 4.0
Keywords: Cc:

Description

If you select all content in the editor (keyboard or icon) and then press delete, the editor is removed from the page.

This only happens when enterMode is CKEDITOR.ENTER_BR

Tested against revision 3500 nightly build, and happens in Chrome, Firefox and IE.

To replicate:

  1. Visit: https://dl.dropbox.com/u/2510419/CKExample/index.html
  2. Click into text
  3. Select All (icon or keyboard)
  4. Press delete

Attachments (1)

__inlinetest.html (633 bytes) - added by Jakub Ś 10 years ago.

Download all attachments as: .zip

Change History (13)

Changed 10 years ago by Jakub Ś

Attachment: __inlinetest.html added

comment:1 Changed 10 years ago by Jakub Ś

Status: newconfirmed

Confirmed. Press CRTL+A and press delete. Once the delete is pressed whole table gets removed from DOM.

Problem occurs with or without enter mode set to BR but the key to reproduce is having div is placed inside table.

Last edited 10 years ago by Jakub Ś (previous) (diff)

comment:2 Changed 10 years ago by Jakub Ś

#9382 was marked as duplicate.

comment:3 Changed 10 years ago by Fasihi

Happens with entermode ENTER_P too, if you select all in an empty editor

comment:4 Changed 10 years ago by Jakub Ś

Summary: Editor is removed when deleting all content and enterMode is CKEDITOR.ENTER_BREditor is removed when deleting all content and editor (div) is inside table

comment:5 Changed 10 years ago by Garry Yao

Milestone: CKEditor 4.0

This's an important issue to be considered in v4.

comment:6 Changed 10 years ago by Garry Yao

Owner: set to Garry Yao
Status: confirmedassigned

Regression of [7243], affected list as well.

Last edited 10 years ago by Garry Yao (previous) (diff)

comment:7 Changed 10 years ago by Garry Yao

Status: assignedreview

Besides of fix the bug, it looks like it's not appropriate to alter the behavior of getSelectedElement in general, and much safer to have #7645 just fixed by the keystroke handler.

comment:8 Changed 10 years ago by Jakub Ś

This is very similar issue to inline editing #9482. Perhaps they have the same solution.

comment:9 Changed 10 years ago by Piotrek Koszuliński

Status: reviewreview_passed

This patch fixes also #9482.

comment:10 Changed 10 years ago by Piotrek Koszuliński

I pushed rebased branches. Note that dev branch wasn't based on master, so I had to remove one commit after rebase.

comment:11 Changed 10 years ago by Garry Yao

Resolution: fixed
Status: review_passedclosed

comment:12 Changed 10 years ago by Fasihi

confirmed fixed! Thank you!

Note: See TracTickets for help on using tickets.
© 2003 – 2022, CKSource sp. z o.o. sp.k. All rights reserved. | Terms of use | Privacy policy