Opened 6 years ago

Closed 6 years ago

#9423 closed Task (fixed)

Implement Moono as our default skin

Reported by: Frederico Caldeira Knabben Owned by: Olek Nowodziński
Priority: Normal Milestone: CKEditor 4.0
Component: UI : Skins Version:
Keywords: Cc:

Description

"Moono" is the winner of the CKEditor 4 Skin Contest.

Now we need to take the contest submitted files and work on them for their perfection, making this skin the default one in the development code.

Attachments (11)

ie9DialogFooterNoTopLine.png (6.2 KB) - added by Olek Nowodziński 6 years ago.
colorPickerNarrowInputs.png (38.8 KB) - added by Olek Nowodziński 6 years ago.
ie7DialogIssues.png (10.8 KB) - added by Olek Nowodziński 6 years ago.
IEUIcolorTabsActive.png (4.9 KB) - added by Olek Nowodziński 6 years ago.
scr1.png (8.5 KB) - added by Piotrek Koszuliński 6 years ago.
scr2.png (31.5 KB) - added by Piotrek Koszuliński 6 years ago.
scr3.png (6.7 KB) - added by Piotrek Koszuliński 6 years ago.
scr4.png (10.6 KB) - added by Piotrek Koszuliński 6 years ago.
scr5.png (3.1 KB) - added by Piotrek Koszuliński 6 years ago.
scr6.png (12.1 KB) - added by Piotrek Koszuliński 6 years ago.
scr7.png (10.8 KB) - added by Piotrek Koszuliński 6 years ago.

Download all attachments as: .zip

Change History (20)

comment:1 Changed 6 years ago by Jakub Ś

Status: newconfirmed

comment:2 Changed 6 years ago by Frederico Caldeira Knabben

Branch t/9423@cksource started with the original Moono files.

comment:3 Changed 6 years ago by Frederico Caldeira Knabben

Owner: set to Frederico Caldeira Knabben
Status: confirmedassigned

comment:4 Changed 6 years ago by Olek Nowodziński

Owner: changed from Frederico Caldeira Knabben to Olek Nowodziński

comment:5 Changed 6 years ago by Olek Nowodziński

Status: assignedreview

A pre-review of t/9423@cksource is requested to speed up development. Thus:

  • This branch still has no good IE7 support.
  • HC hasn't been tested yet...
  • ...as well as quirks.

Important things to consider:

  • Changes in core/skin.js
  • Changes in panel plugin
  • Decent modern-browser support.
  • Decent UI Color support.

If something's wrong, screenshots are welcome.

Changed 6 years ago by Olek Nowodziński

Changed 6 years ago by Olek Nowodziński

Attachment: colorPickerNarrowInputs.png added

Changed 6 years ago by Olek Nowodziński

Attachment: ie7DialogIssues.png added

Changed 6 years ago by Olek Nowodziński

Attachment: IEUIcolorTabsActive.png added

comment:6 Changed 6 years ago by Olek Nowodziński

Bugs so far:

  • No document properties icon
  • Various UI issues (mostly IE):

Last edited 6 years ago by Olek Nowodziński (previous) (diff)

comment:7 Changed 6 years ago by Piotrek Koszuliński

My first impression from Chrome is that skin is nearly finished. I've found few minor issues:

  • Beige borders around smiles in smiles dialog.
  • No vertical space between selected color and its hex representation in color picker (scr1).
  • No visual partition between characters in special characters dialog.
  • Disabled inputs are too dark (scr2).
  • There's a strange shadow under the text in buttons inside dialogs (scr2).
  • Text in native select is too low (scr3).
  • Blue links in about dialog don't look good.
Last edited 6 years ago by Olek Nowodziński (previous) (diff)

Changed 6 years ago by Piotrek Koszuliński

Attachment: scr1.png added

Changed 6 years ago by Piotrek Koszuliński

Attachment: scr2.png added

Changed 6 years ago by Piotrek Koszuliński

Attachment: scr3.png added

comment:8 Changed 6 years ago by Piotrek Koszuliński

Few more issues:

  • (scr4) On Firefox box-shadow: inset is much stronger than on Chrome. I like the Chrome's version more, because it's cleaner. What's more - this shadow is rendered only... sometimes (scr7). It's definitely FF's bug but maybe we can bypass it.
  • (scr5) Again on FF box shadow is too strong - much stronger than on Chrome.
  • (scr6) Format combo reacted on hover even though I was in source mode.
  • There's a second issue with combos - on Chrome they have separate "active" style (when mouse button is down), on FF now. And when SCAYT menu is opened it has this "active" style, but when style combos are opened they have normal style.
  • On IE8 cursor isn't change over buttons in the dialog footer (... ok, it is but not if over text).
Last edited 6 years ago by Olek Nowodziński (previous) (diff)

Changed 6 years ago by Piotrek Koszuliński

Attachment: scr4.png added

Changed 6 years ago by Piotrek Koszuliński

Attachment: scr5.png added

Changed 6 years ago by Piotrek Koszuliński

Attachment: scr6.png added

Changed 6 years ago by Piotrek Koszuliński

Attachment: scr7.png added

comment:9 Changed 6 years ago by Olek Nowodziński

Resolution: fixed
Status: reviewclosed

Branch t/9423 closed with a commit merged into master.

Further Moono development and fixing goes here.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy