Opened 7 years ago

Closed 7 years ago

#9529 closed Bug (fixed)

[IE] Paragraph format not reflected on selection

Reported by: Garry Yao Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 4.0
Component: General Version: 4.0
Keywords: IE Cc:

Description

  1. Load replacebyclass sample;
  2. Put cursor in the heading line;
  3. Open Format combo and select the H2 format
  • Actual: H2 format is not immediately reflected after combo is closed.

Change History (7)

comment:1 Changed 7 years ago by Garry Yao

Status: newconfirmed

Regression of b46dd71817 (Prevent incorrect combo's state change on selectionChange thrown after it's opened.)

comment:2 Changed 7 years ago by Piotrek Koszuliński

But it's caused by selectionChange not fired after style is applied. Or this event is fired when combo is still opened.

Last edited 7 years ago by Piotrek Koszuliński (previous) (diff)

comment:3 Changed 7 years ago by Garry Yao

Owner: set to Garry Yao
Status: confirmedreview

Yeah, this event is fired when combo is closing down, that's not wrong though.

I proposed another fix for #9487 at t/9529.

comment:4 Changed 7 years ago by Garry Yao

Pushed one commit to address #9508 as well.

comment:5 Changed 7 years ago by Piotrek Koszuliński

Status: reviewreview_passed

I'd like to see some docs there, because it took me some time to figure out why do we need lastState :).

comment:6 Changed 7 years ago by Piotrek Koszuliński

Oh - and reformat if () {, please.

comment:7 Changed 7 years ago by Garry Yao

Resolution: fixed
Status: review_passedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy