Opened 7 years ago

Closed 7 years ago

#9549 closed Bug (fixed)

Safari: cke_pastebin remains in editor body after pasting

Reported by: Jakub Ś Owned by: Piotrek Koszuliński
Priority: Normal Milestone: CKEditor 4.0
Component: Core : Pasting Version: 4.0
Keywords: Safari IBM Cc: satya_minnekanti@…

Description

To reproduce the defect:

  1. Open Replace by class sample and clear editor contents. Copy HTML content from above editor body and paste in to editor.
  2. Go back to HTML Source. See that cke_pastebin shows at end of editor content.
    <body id="cke_pastebin" style="position: absolute; top: 39px; width: 1px; height: 1px; overflow-x: hidden; overflow-y: hidden; left: -1000px; "> </body>
    
  3. Switch back to Rich text.
  4. Content lost and we can't type in to editor.

This is because cke_pastebin still remains in editor body.

This was fixed in CKE 3.x but is still present in CKE 4.x

Reproducible in Safari on Windows (Checked under 7 and XP)

Change History (8)

comment:1 Changed 7 years ago by Jakub Ś

Status: newconfirmed

comment:2 Changed 7 years ago by Satya Minnekanti

Cc: satya_minnekanti@… added
Keywords: IBM added

comment:3 Changed 7 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.0.1
Owner: set to Piotrek Koszuliński
Status: confirmedassigned

comment:4 Changed 7 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.0.1CKEditor 4.0

comment:5 Changed 7 years ago by Piotrek Koszuliński

Status: assignedreview

Pushed t/9549 on review.

comment:6 Changed 7 years ago by Garry Yao

Status: reviewreview_failed

We just need to keep the v3 code line orders for simplicity.

comment:7 Changed 7 years ago by Piotrek Koszuliński

Status: review_failedreview

Pushed t/9549b. It's simplified v3's patch proposed for #9514.

comment:8 Changed 7 years ago by Garry Yao

Resolution: fixed
Status: reviewclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy