Opened 6 years ago

Closed 4 years ago

#9638 closed Bug (fixed)

a11yhelp availablity

Reported by: Garry Yao Owned by: Piotrek Koszuliński
Priority: Normal Milestone: CKEditor 4.4.3
Component: Accessibility Version: 4.0
Keywords: IBM Cc: irinauru@…, satya_minnekanti@…

Description

With preset-basic build profile, the editor is built without the a11yhelp plugin, this causes a issue as the ARIA information still prompts the ALT-0 help info.

Change History (17)

comment:1 Changed 6 years ago by Piotrek Koszuliński

It's a similar issue to #9541. Since we postponed that one, we perhaps should do the same with this one.

comment:2 Changed 6 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 4.0CKEditor 4.0.1
Status: newconfirmed

comment:3 Changed 6 years ago by Garry Yao

Let's wait for #9541 to be closed first.

comment:4 Changed 6 years ago by Garry Yao

Owner: set to Garry Yao
Status: confirmedassigned

comment:5 Changed 6 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 4.0.1

comment:6 Changed 6 years ago by Piotrek Koszuliński

Owner: Garry Yao deleted
Status: assignedconfirmed

comment:7 Changed 5 years ago by Mike Gifford

Ok, #9541 is closed now. Can we get the preset-basic built with a11yhelp plugin?

comment:8 Changed 4 years ago by Irina

Cc: irinauru@… added
Keywords: IBM added

comment:9 Changed 4 years ago by Satya Minnekanti

Cc: satya_minnekanti@… added

add to cc

comment:10 Changed 4 years ago by Piotrek Koszuliński

Owner: set to Piotrek Koszuliński
Status: confirmedassigned

comment:11 Changed 4 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.4.3

Solution for this needs to be based on an even (e.g. editor#ariaEditableLabel, or more specific referring to a11y help), because a11y must be able to mark its presence. The event will return expected label that will be used by wysiwygarea plugin or editable (title is set in both places).

There are, however, two questions which answers I'm not sure:

  1. What with the .cke_voice_label element and aria-describedby attribute if there's no a11y plugin? Should they be not created at all?
  2. In wysiwygarea, on IE we prepend editor.title to the lang.common.editorHelp. If a11y help will be missing should this title be still prepended?

comment:12 in reply to:  11 ; Changed 4 years ago by Frederico Caldeira Knabben

Replying to Reinmar:

  1. What with the .cke_voice_label element and aria-describedby attribute if there's no a11y plugin? Should they be not created at all?

I think so. Accessibility should still be available, even if the a11yhelp plugin is not there.

  1. In wysiwygarea, on IE we prepend editor.title to the lang.common.editorHelp. If a11y help will be missing should this title be still prepended?

No. Shouldn't this be achieved by the proposed event as well?

comment:13 in reply to:  12 ; Changed 4 years ago by Piotrek Koszuliński

Replying to fredck:

Replying to Reinmar:

  1. What with the .cke_voice_label element and aria-describedby attribute if there's no a11y plugin? Should they be not created at all?

I think so. Accessibility should still be available, even if the a11yhelp plugin is not there.

I don't understand. Maybe my question was not clear. We use .cke_voice_label only for the lang.common.editorHelp (IE & wysiwygarea is an exception - see next point). If there's no a11yhelp plugin this element will be empty. Should it be created or not in this case? I think that it shouldn't be created.

  1. In wysiwygarea, on IE we prepend editor.title to the lang.common.editorHelp. If a11y help will be missing should this title be still prepended?

No. Shouldn't this be achieved by the proposed event as well?

Event solves adding conditionally lang.common.editorHelp. Then we've got editor.title prepended but only on IE and only in wysiwygarea. So I think this logic has to be kept there, in the wysiwygarea plugin. The question was whether editor.title should be added when there's no a11yhelp plugin, but I understand that no.

comment:14 in reply to:  13 Changed 4 years ago by Frederico Caldeira Knabben

Replying to Reinmar: Yes, I think attributes should not be created/filled if they're supposed to be empty. But really, only during implementation and testing we'll be able to figure this out. It's something to get decided on the spot.

comment:15 Changed 4 years ago by Piotrek Koszuliński

Status: assignedreview

comment:16 Changed 4 years ago by Marek Lewandowski

Status: reviewreview_passed

Seems to be ok, pushed minor changes.

comment:17 Changed 4 years ago by Marek Lewandowski

Resolution: fixed
Status: review_passedclosed

Fixed with git:7419ad5844 (merged to master) at dev.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy