Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#9695 closed Bug (duplicate)

A11Y: Not possible to navigate out of Table without using Magicline

Reported by: Satya Minnekanti Owned by:
Priority: Normal Milestone:
Component: Accessibility Version: 4.0
Keywords: IBM Cc: Damian, Teresa Monahan

Description

To reproduce the defect:

  1. Open Ajax sample & insert a table with default values.
  1. Navigate to empty paragraph after the table and press Backspace
  1. Empty paragraph after tables gets deleted & cursor moves to last table cell.
  1. Now press down arrow key to come out of the table.

Issue: we can't come out of the table using keyboard. This is an Accessibility Compliance issue, since Magicline feature not accessible using keyboard

Change History (6)

comment:1 Changed 7 years ago by Jakub Ś

Component: GeneralAccessibility
Status: newconfirmed

Magic line was created to avoid all these "orphan paragraph" bugs (this is one of reasons).

Indeed, since it is only possible to click on Magic line this is an Accessibility Compliance issue.

@satya could some keyboard shortcut (for magic line) to insert new line below or above element could solve this problem?

comment:2 Changed 6 years ago by Satya Minnekanti

This defect does not exist in 3.x stream & it's only happening for 4.0. So definitely a regression

comment:3 Changed 6 years ago by Jakub Ś

Yes but in CKE 3.x you were able to create paragraph below table by simply pressing arrow - it is very easy to create such paragraph by accident and then save data. I was confusing some of our users.

Magic line was introduced to remove this problem. I'm not sure if Creating P on arrow will be reintroduced (hope not) but perhaps adding keystrokes to magic line would be a solution? That is why I have asked you about your opinion on this.

comment:4 in reply to:  3 Changed 6 years ago by Satya Minnekanti

Replying to j.swiderski:

Yes but in CKE 3.x you were able to create paragraph below table by simply pressing arrow - it is very easy to create such paragraph by accident and then save data. I was confusing some of our users.

Magic line was introduced to remove this problem. I'm not sure if Creating P on arrow will be reintroduced (hope not) but perhaps adding keystrokes to magic line would be a solution? That is why I have asked you about your opinion on this.

@J.swiderski Magicline is only visible when user hovers mouse over area where there is no paragraph, but JAWS user won't use mouse. How can JAWS user know when & where he can use the shortcut for Magicline

comment:5 Changed 6 years ago by Piotrek Koszuliński

Resolution: duplicate
Status: confirmedclosed

DUP of #9481.

comment:6 Changed 6 years ago by Olek Nowodziński

Issue solved with #9481.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy