Opened 6 years ago

Closed 5 years ago

#9696 closed Bug (fixed)

IE: Text between list items getting overlapped when list items text has font size more than 36

Reported by: Satya Minnekanti Owned by:
Priority: Normal Milestone: CKEditor 4.3.2
Component: General Version: 4.0
Keywords: IBM Cc: Damian, Teresa Monahan

Description

To reproduce the defect:

  1. Open Ajax sample, select font size of 48 and type some text.
  1. Select the text and click on Numbered/Bulleted list icon.
  1. Numbered/Bulleted list created with one list item.
  1. Press enter at end of list item to create new list item.
  1. Start typing the text in new list item.

Issue: see that the text in list items getting overlapped.

Change History (7)

comment:1 Changed 6 years ago by Jakub Ś

Status: newconfirmed

This problem can be reproduced in IE browsers in CKEditor 4 master only (It was working on beta).

In IE7 all you have to do is select font size 48 and start typing - you will notice that span (without any list) overlaps text.

NOTE: In CKEditor 3.x (after step 4) cursor is at position to overlap previous list item but once you start typing it goes to correct place.

comment:2 Changed 6 years ago by Teresa Monahan

We can no longer reproduce this in any of the CKEditor 4 releases.

comment:3 Changed 6 years ago by Jakub Ś

I was still able to reproduce this problem in all browsers in sample pages in latest CKEditor 4.2 and latest master.

comment:4 in reply to:  3 Changed 6 years ago by Teresa Monahan

Replying to j.swiderski:

I was still able to reproduce this problem in all browsers in sample pages in latest CKEditor 4.2 and latest master.

Sorry, this is reproducible on nightly builds. We are using a customized content.css file where we do not include the following rule:

.cke_editable {
    line-height: 1.6em;
}

I believe this rule is the cause of the problem in nightly builds.

comment:5 Changed 6 years ago by Jakub Ś

@tmonahan , you are right removing this rule resolves the problem - I will forward this issue.

comment:6 Changed 5 years ago by Piotrek Koszuliński

#11379 contains a solution for this problem. We'll include it in 4.3.2 if it passes review.

comment:7 Changed 5 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.3.2
Resolution: fixed
Status: confirmedclosed

Fixed by #11379.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy