Opened 7 years ago

Closed 7 years ago

#9714 closed Bug (wontfix)

CSS for span imcomplete.

Reported by: Sam Mousa Owned by:
Priority: Normal Milestone:
Component: UI : Skins Version:
Keywords: Cc:

Description

When the page including CKeditor has defined a display setting for all spans comboboxes display incorrect.

This can be fixed by adding. table.cke_editor span {

display: inline

}

Currently it is assumed that no previous setting was applied, this does not have to be the case and therefore forcing the correct setting seems like a good idea to me!

Change History (4)

comment:1 Changed 7 years ago by Jakub Ś

Status: newpending
Version: 3.6.5

display incorrect.

This is jus to little information. Please tell us what gets broken and under what circumstances. Also please provide plain HTML sample showing the problem.

comment:2 Changed 7 years ago by Sam Mousa

Just include a css rule into your page specifying span { display: inline-block; }

This will break the combobox used to select stuff like styles.

In any case, making assumptions about the state of css settings is inherently flawed since cascading does exactly the opposite.

If the layout for CKEditor requires spans to be displayed inline and not inline-block than it should define a css rule for that.

comment:3 Changed 7 years ago by Jakub Ś

But span elements are inline by design. What sort of scenario made you use spans as inline-block? You could use divs for that which would be much more correct.

Currently I think that this issue is invalid but please describe this scenario as I may be wrong.

comment:4 Changed 7 years ago by Jakub Ś

Resolution: wontfix
Status: pendingclosed

After some consultation with my colleagues we have come to conclusion:

There is a huge number of cases that could bring similar issues. It is impossible for the editor to reset every single CSS property of every element to their defaults. We don it just for the most common conflict cases. Chancing the "inline" definition of all spans in a page is not a common practice.

There forefore, the right way to fix this issue is by having your system doing the reset job, by simply fixing the all spans inside the CKEditor interface.

in CKEditor 3, the skin class (e.g. cke_skin_kama) is applied to the outer span of the UI. In CKEditor 4, the ".cke" class has been added, to make it easier to manage this. Just use these classes to have things fixed

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy