Opened 7 years ago

Closed 7 years ago

#9792 closed New Feature (duplicate)

Collapsing only 2nd+ toolbar rows

Reported by: giammin Owned by:
Priority: Normal Milestone:
Component: UI : Toolbar Version:
Keywords: Cc:

Description

Normally CKEditor hides/shows all the toolbar buttons when you press the collapse/expand button. It would be nice to always show the first row with “basic tools” and only collapse the second and following rows with advanced functionality tool buttons.

http://theholyjava.wordpress.com/2011/04/01/ckeditor-collapsing-only-2nd-toolbar-rows-howto/

It would be nice to have this funcionality in inline edit mode(toolbarCanCollapse does not work)

Change History (2)

comment:1 Changed 7 years ago by Jakub Ś

This is duplicate of #7280.

Athougt presented trick is a little bit different than #7280 the concept is the same. It should be possible to change toolbar after init.

Proper way is not to change rows but definitions (I have showed such example for maximize command). It this case there should be something like full toolbar definition which is changed to specialized definition with specified plugins when collapse toolbar button is pressed.
Whether this is happening when collapse toolbar is pressed or e.g. maximize buttonis pressed, should be implemented by user. We only need to provide ability to do so (hooks).

comment:2 Changed 7 years ago by Jakub Ś

Resolution: duplicate
Status: newclosed

@giammin - The only thing that is missing here is collapse toolbar for inline mode. It was not implemented because we haven't seen any real use case for it.

This could be one of them thus I have reported separate feature request for it- #9871.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy