Opened 6 years ago

Closed 5 years ago

#9802 closed Bug (duplicate)

Load iframe with editor in hidden DIV

Reported by: Damian Owned by:
Priority: Normal Milestone:
Component: General Version: 3.5.2
Keywords: Firefox Cc:

Description

When you try to load iframe with editor in hidden DIV and after that you change visibility of this div, the editor toolbar show without images of buttons (only alt of images are visible in buttons).
I reproduce this bug only in Firefox (for me it's FF 17.0.1 - Windows 7).
I've add test case for this issue in attachment.

Attachments (2)

TC.zip (691.0 KB) - added by Damian 6 years ago.
_mytest.html (440 bytes) - added by Jakub Ś 6 years ago.

Download all attachments as: .zip

Change History (6)

Changed 6 years ago by Damian

Attachment: TC.zip added

comment:1 Changed 6 years ago by Michał

The problem is not that buttons are 'missing' but that editor is set to high contrast mode. This is caused by both sides of comparison:

CKEDITOR.env.hc = hcDetect.getComputedStyle( 'border-top-color' ) == hcDetect.getComputedStyle( 'border-right-color' );

(in core/_bootsrap.js) are empty strings. This happens only in Firefox. In other browsers getComputedStyle returns red & blue.

comment:2 Changed 6 years ago by Jakub Ś

Keywords: Firefox added
Status: newconfirmed
Version: 4.03.5.2

I was able to reproduce this problem in Firefox only.

This particular TC can be reproduced from CKEditor 4.0.

I think the problem first started in CKEditor 3.5.2 rev [6454]. JS error is thrown with this revision:
URI: ckeditor/_source/core/dom/element.js
Message : TypeError: this.getWindow(...).$.getComputedStyle(...) is null
Line: 495

In CKEditor 3.6.5 something got changed that causes error in firebug script (at least in my browser). This continued to CKEDitor 4 beta and changed in CKEditor 4.0.

Changed 6 years ago by Jakub Ś

Attachment: _mytest.html added

comment:3 Changed 6 years ago by Jakub Ś

Another TC. Just put _mytest.html in samples folder and in Firefox you will see that editor goes into HC mode.

comment:4 Changed 5 years ago by Piotrek Koszuliński

Resolution: duplicate
Status: confirmedclosed

DUP of #11121.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy