Opened 6 years ago

Closed 6 years ago

#9953 closed New Feature (duplicate)

Do not process non editable element HTML

Reported by: j.salak Owned by:
Priority: Normal Milestone:
Component: Core : Editable Version:
Keywords: Cc:

Description

In inline editing mode i like to use other jQuery plugins for specified parts of code (image gallery, etc.) on specified element (div class="gallery", etc.). So i like to prevent them from CKEditor editing (by contenteditable=false) but CKEditor process their source code and ruins iQuery plugin's interface.

Attachments (1)

ckeditor-protected.html (1.9 KB) - added by j.salak 6 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 6 years ago by Jakub Ś

Keywords: noneditable protect jquery removed
Status: newpending

Could you provide sample HTML page showing this problem (something that can be put in samples and will work)? As for jQuery links - code can be linked from Google code.

Changed 6 years ago by j.salak

Attachment: ckeditor-protected.html added

comment:2 Changed 6 years ago by Piotrek Koszuliński

Status: pendingconfirmed
Type: BugNew Feature

I think that this is DUP of #9764 and at the same time "invalid" or rather "wontfix". Widgets will make it possible to make non-editable containers, but these containers won't behave as normal elements - e.g. when data are reloaded (undo/redo/sourcearea/etc) the old DOM is destroyed so listeners have to be added. Therefore to include real jQ gallery one would have to write full widget wrapping it.

However, I can also think about different solution. Such non-editable container can be stored by reference and restored (the same element - not the same HTML) after data are set. However, I think that usual jQ gallery will blow up in such an environment. This is a hardcore scenario.

I confirm this as a new feature but at the same time I'm predicting that it's very unlikely that anyone will work on it. It's extremely complicated and at the same time can be achieved by placeholders implemented by widgets or fakeobjects.

Last edited 6 years ago by Piotrek Koszuliński (previous) (diff)

comment:3 Changed 6 years ago by Piotrek Koszuliński

Resolution: duplicate
Status: confirmedclosed

Yes, this was a duplicate of #9764. Such scenarios have to be handled by widgets.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy