Opened 7 years ago

Closed 6 years ago

#10212 closed Bug (fixed)

[IE7-10] Undo gives JS error after 2+ switches to source mode.

Reported by: Joel Owned by: Piotrek Koszuliński
Priority: Normal Milestone: CKEditor 4.0.3
Component: General Version: 4.0.1
Keywords: IE IBM Cc:

Description

Reproducible in IE9 in http://ckeditor.com/demo and nightly 13-03-13-08-51

  1. Do any undoable change, like add HR
  2. Go to source mode and switch back
  3. Go to source mode and switch back again
  4. Click undo icon or press Ctrl-Z

The error comes in IE developer tools console. For me the error was

SCRIPT70: Ei käyttöoikeutta 
ckeditor.js?mjldea, rivi 58 merkki 486

IE9, Win 7 64bit. Not reproducible in Chrome or Firefox.

Change History (8)

comment:1 Changed 7 years ago by Jakub Ś

Keywords: IE added
Status: newconfirmed
Summary: [IE9] Undo gives JS error after 2+ switches to source mode.[IE7-10] Undo gives JS error after 2+ switches to source mode.
Version: 4.0.24.0.1

Problem can be reproduced all versions of IE from CKEditor 4.0.1.

JS Error:
Message: Access Denied
Line: 190
URI: ckeditor4/core/dom/document.js

comment:2 Changed 7 years ago by Jakub Ś

Keywords: IBM added

Another TC from IBM:

  1. Open any CK Editor sample, enter some text
  2. Switch to Source view and back to rich text again.
  3. Keep cursor in editor body, type some more text, Now click Undo icon or Ctrl + Z

#10216 was marked as duplicate.

comment:3 Changed 7 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.0.3

comment:4 Changed 7 years ago by Piotrek Koszuliński

I pushed t/10212 on dev with simple patch that seems to fix this issue. I'm not putting this ticket on review, since test should be wrriten.

Last edited 7 years ago by Piotrek Koszuliński (previous) (diff)

comment:5 Changed 7 years ago by Piotrek Koszuliński

Owner: set to Piotrek Koszuliński
Status: confirmedassigned

comment:6 Changed 7 years ago by Piotrek Koszuliński

Status: assignedreview

I pushed a test on t/10212. I couldn't reproduce this issue from code on IE9, but test correctly fails on IE8 and IE7.

comment:7 in reply to:  6 Changed 6 years ago by Olek Nowodziński

Status: reviewreview_passed

Replying to Reinmar:

I pushed a test on t/10212. I couldn't reproduce this issue from code on IE9, but test correctly fails on IE8 and IE7.

There's one browser that is affected by this issue but passes TC without the patch, namely IE10. This is a minor issue though, so R+.

comment:8 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: review_passedclosed

Fixed on master with git:2c54f8d on dev and 2a8e535 on tests.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy