Opened 6 years ago

Closed 6 years ago

#10503 closed Bug (duplicate)

Alt + F10 doesn't work on Ubuntu

Reported by: Piotr Jasiun Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: Linux Cc:

Description (last modified by Piotr Jasiun)

Shortcut Alt + F10 should move focus to toolbar. But on Ubuntu 12.04 it is captured by system. I checked it with Chrome 27 and FF 21.

Change History (8)

comment:1 Changed 6 years ago by Piotr Jasiun

Description: modified (diff)

comment:2 Changed 6 years ago by Olek Nowodziński

In my opinion this is not a bug since this is a native behavior of the OS:

https://bugs.launchpad.net/ubuntu/+source/unity/+bug/955965/comments/3

To be confirmed.

comment:3 Changed 6 years ago by Jakub Ś

Problem can be reproduced from CKEditor 3.0.

In Firefox and Chrome shortcut Alt+F10 opens browser top menu. In Opera it doesn't work at all. Other shortcuts seem to work fine.

Another problem with Alt+F10 is that it is used to move through dialog tabs so with this feature not working we have no access to Toolbar and dialog Tabs on Linux.

I think solution is introducing different shortcut for Linux.

comment:4 Changed 6 years ago by Jakub Ś

I have checked Mac and shortcuts work fine there. I don't think it is a good idea to leave Ubuntu without Alt+F10.

@fredck could you perhaps comment?

comment:5 Changed 6 years ago by Jakub Ś

Keywords: Linux added
Status: newconfirmed
Version: 4.1.2 (GitHub - master)3.0

comment:6 Changed 6 years ago by Frederico Caldeira Knabben

It is not something good, but it is not a big deal for now.

At least in terms of a11y, our target is Firefox+JAWS+WIndows, so we don't have impact.

comment:7 Changed 6 years ago by Wiktor Walc

Looks like a duplicate of #7505 ?

comment:8 Changed 6 years ago by Piotr Jasiun

Resolution: duplicate
Status: confirmedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy