Opened 6 years ago

Closed 6 years ago

#10707 closed Bug (fixed)

JAWS not reading label for Color's list box & we can't navigate through color options using keyboard

Reported by: Satya Minnekanti Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: CKEditor 4.2.2
Component: Accessibility Version: 4.1.2
Keywords: IBM Cc: Damian, Teresa Monahan, Irina

Description

To reproduce the defect:

  1. With JAWS on, open any CK Editor sample
  1. Navigate to Text Color or Background color menu in the toolbar and press Enter

Expected Result: Color list box opens, JAWS read aria-label for list box which is Colors

Actual Result: JAWS just reads menu & says use arrow keys to navigate through options.

Press Down arrow key once.

Expected Result: Focus goes to first color option & JAWS read that option.

Actual Result: Focus not going to first option, JAWS reading next button in the toolbar group or sometimes it reads elements path bar when we use down arrow key few times.

We are using FF22 & JAWS14

Change History (6)

comment:1 Changed 6 years ago by Jakub Ś

Status: newconfirmed
Version: 4.1.2

I was able to reproduce this problem on Windows 7/8 with JAWS 14 and FF23.

I can confirm JAWS has not been reading "Colors" aria-label from CKEditor 4.1.2.

About navigation - this part is exactly the same as in #10706 and #10705. You need to press TAB in order to focus menu and then you can navigate with arrows.

NOTE: In my case there was no message about arrows.

comment:2 Changed 6 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 4.2.2

comment:3 Changed 6 years ago by Frederico Caldeira Knabben

Owner: set to Frederico Caldeira Knabben
Status: confirmedassigned

comment:4 Changed 6 years ago by Frederico Caldeira Knabben

This seems to be very related to #10706, so we'll wait for that ticket to have a conclusion first.

comment:5 Changed 6 years ago by Frederico Caldeira Knabben

Supposed to be fixed by #10951.

comment:6 Changed 6 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

Fixed by #10951.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy