Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#11134 closed Bug (fixed)

Widgets support for divarea

Reported by: Piotrek Koszuliński Owned by: Piotr Jasiun
Priority: Must have (possibly next milestone) Milestone: CKEditor 4.3.2
Component: UI : Widgets Version: 4.3 Beta
Keywords: Cc:

Description (last modified by Piotrek Koszuliński)

We need to identify issues first, so this ticket requires tests.

Identified issues:

Attachments (1)

ckeditor_widget_divarea_multi_instance_bug.zip (787.9 KB) - added by Joss 5 years ago.
Widget + divarea multi-instance bug

Download all attachments as: .zip

Change History (17)

comment:1 Changed 6 years ago by Jakub Ś

Status: newconfirmed

comment:2 Changed 6 years ago by Piotrek Koszuliński

Summary: Widgets support for divarea[Umbrella] Widgets support for divarea

comment:3 Changed 6 years ago by Piotrek Koszuliński

Priority: NormalHigh

comment:4 Changed 5 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.3.1CKEditor 4.3.2

Rearranged tickets due to new ones which have high priority.

comment:5 Changed 5 years ago by Marek Lewandowski

Description: modified (diff)

comment:6 Changed 5 years ago by Olek Nowodziński

Description: modified (diff)
Resolution: invalid
Status: confirmedclosed

Closing since #10787 has nothing to do with widgets and there's no need for umbrella anylonger.

comment:7 Changed 5 years ago by Olek Nowodziński

Description: modified (diff)
Resolution: invalid
Status: closedreopened
Summary: [Umbrella] Widgets support for divareaWidgets support for divarea

comment:8 Changed 5 years ago by Piotrek Koszuliński

Description: modified (diff)
Status: reopenedconfirmed

comment:9 Changed 5 years ago by Marek Lewandowski

Since this ticket is not umbrella anymore, and it links only to #11131 issue, do we need to keep this issue?

comment:10 in reply to:  9 Changed 5 years ago by Olek Nowodziński

Replying to m.lewandowski:

Since this ticket is not umbrella anymore, and it links only to #11131 issue, do we need to keep this issue?

Yeah, unfortunately we have to as it turned out recently. This ticket is to keep in mind that we got to test widgets in divarea, something that we apparently missed. There could be dozens of issues concerning such conjunction, we need to check this out and submit bugs for upcoming milestones.

comment:11 Changed 5 years ago by Piotr Jasiun

Owner: set to Piotr Jasiun
Status: confirmedassigned

comment:12 Changed 5 years ago by Piotr Jasiun

I've added divarea editors to dev samples for placeholder, image2 and mathjax plugins (in t/11134) and tested them on Chrome, FF and IE 8-11. I get some random errors on IE 8 and 9 but I was not able to reproduce them. Excluding them everything works fine.

Someone with mac can test everything on Safari if we want to have full test coverage.

Last edited 5 years ago by Piotr Jasiun (previous) (diff)

comment:13 Changed 5 years ago by Piotrek Koszuliński

It's ok for me to close this ticket now. We'll check Safari during the testing phase. You can close this ticket.

comment:14 Changed 5 years ago by Piotr Jasiun

Resolution: fixed
Status: assignedclosed

I've added changed in dev samples to master (git:f5676b6).

Changed 5 years ago by Joss

Widget + divarea multi-instance bug

comment:15 Changed 5 years ago by Joss

I've seen some strange behaviour : I've created two instances of ckeditor, both with divarea, one with a widget dependant module, the other without widget. Then, there's some bugs with widget features (move, mask ...). If I add the widget module to the first ckeditor instance, then it works like a charm. So, if I have multiple instance of ckeditor with divarea, each instance must use widget in order to get widgets working on instances that need it.

comment:16 Changed 5 years ago by Piotrek Koszuliński

That's a bug with sharing contents CSS between editor instances. Stylesheet with editor-specific contents styles is appended to <head> during first editor initialization. Styles for second editor are not added after that.

The unfortunate thing is that there's no easy solution that we could implement. CKEDITOR.getCss would have to create stylesheet and keep reference to it, so when next CKEDITOR.addCss is called, it could update all stylesheets. Or upon 2nd and later editors initialization the stylesheet appended to CKEDITOR.document (the one that's shared) has to be refreshed. The second option sounds better, but I need to think it through.

I'll create separate ticket for this bug. The workaround for now is having widget plugin always loaded (in both editors).

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy