Opened 4 years ago

Closed 4 years ago

#11983 closed Bug (fixed)

[Nested widgets] Clicking nested widget does not select it

Reported by: Piotrek Koszuliński Owned by: Piotrek Koszuliński
Priority: Normal Milestone: CKEditor 4.4.2
Component: UI : Widgets Version: 4.3 Beta
Keywords: Cc:

Description

Part of #10931.

Since it's not yet possible to automatically initialize nested widgets, download attached sample.

Attachments (1)

11983.html (1.9 KB) - added by Piotrek Koszuliński 4 years ago.

Download all attachments as: .zip

Change History (6)

Changed 4 years ago by Piotrek Koszuliński

Attachment: 11983.html added

comment:1 Changed 4 years ago by Piotrek Koszuliński

Pushed branch:t/11983 with improved implementation of widgetsRepo.getByElement. It will return most inner widget and should perform much better than the previous naive implementation.

Tests and code refactorisation still needed.

PS. Remember that id may be a '0' - case worth testing because incorrect typecasting may break the code.

comment:2 Changed 4 years ago by Piotrek Koszuliński

Status: newconfirmed

comment:3 Changed 4 years ago by Piotrek Koszuliński

Owner: set to Piotrek Koszuliński
Status: confirmedreview

Pushed branch:t/11983 + tests. I also create a widget/dev/nestedwidgets.html sample for manual tests.

comment:4 Changed 4 years ago by Olek Nowodziński

Status: reviewreview_passed

I pushed a single commit to dev branch, which optimises and simplifies CKEDITOR.plugins.widget.repository.getByElement().

I also confirmed a number of issues (#12006, #12007, #12008, #12009 – linked in #10931), which concern nested widgets in general and emerged during the manual tests.

comment:5 Changed 4 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.4.2
Resolution: fixed
Status: review_passedclosed

Thanks for the thorough review. My implementation was more straightforward, but well... two times longer :D.

Fixed on master with git:cb280df on dev and 7768b55 on tests.

BTW. I think we should add also one integration test for clicking. I'll try to add one later.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy