Opened 5 years ago

Closed 5 years ago

#13137 closed Bug (duplicate)

Firefox only - inserting a link using insertHtml and clicking inside editor, causes caret to position incorrectly outside anchor tag

Reported by: Christophe Guillou Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: IBM Cc: Satya Minnekanti, Irina, giogio

Description

Steps to recreate:

CKEDITOR.instances.editor1.insertHtml('<a>hello</a>')

User clicks editable zone of the editor (eg. iframe.body), and after the wording "hello" displays (this means the caret is position after the word "hello")

User types the following characters in the editor " world"

Observed Result = CKEDITOR.instances.editor1.getData()

"<p dir="ltr"><a>hello</a> world</p> "

Expected Result =

CKEDITOR.instances.editor1.getData() "<p dir="ltr"><a>hello world</a></p> "

Note: this is not an issue in Chrome.

Change History (1)

comment:1 Changed 5 years ago by Jakub Ś

Resolution: duplicate
Status: newclosed
Version: 4.4.6

this means the caret is position after the word "hello"

It all depends whether you are inside a link or not. Elements path shows exactly where you are.

This issue is a duplicate of #3509.

Plese see: 7796#comment:4 #8195 and #3509.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy