Opened 10 years ago

Closed 10 years ago

#1682 closed Bug (fixed)

Problem editing control elements in Firefox, Safari, Opera

Reported by: Jeff Johnson Owned by: Martin Kou
Priority: Normal Milestone: FCKeditor 2.6
Component: General Version: FCKeditor 2.5
Keywords: Confirmed FireFox Opera Safari Review+ Cc:

Description (last modified by Frederico Caldeira Knabben)

When you insert a control element and try to edit it, it's current information is not displayed. However, whatever you type in will be properly put into the element you're editing.

  1. Go here: http://www.fckeditor.net/demo
  2. Insert a radio button, checkbox or button
  3. Select the button and try to edit it, it won't get the current information (name, text, selected) for the element
  4. If you click 'OK', it will change the current button whatever you've specified

There seems to be a problem with the getSelection() function somehow; in the pop-up window, FCKSelection.GetSelectedElement() returns a null.

IE 6 and IE 7 don't seem to have the problem, but the following do:

  • Safari 3.0.4
  • Firefox 2.0.0.11
  • Opera 9.5 (build 9613)

Attachments (1)

1682.patch (2.3 KB) - added by Martin Kou 10 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Keywords: Firefox Opera Safari added; control element firefox opera safari removed

This is probably the same problem that #1753

comment:2 Changed 10 years ago by Frederico Caldeira Knabben

Description: modified (diff)

comment:3 Changed 10 years ago by Martin Kou

Keywords: Confirmed FF added; Firefox removed
Milestone: FCKeditor 2.6
Owner: set to Martin Kou
Status: newassigned

Targeting to 2.6 since this is related to some other 2.6 tickets (e.g. #738) and is in itself quite severe.

Changed 10 years ago by Martin Kou

Attachment: 1682.patch added

comment:4 Changed 10 years ago by Martin Kou

Keywords: Review? added

comment:5 Changed 10 years ago by Martin Kou

The submitted patch fixes #1753 as well.

comment:6 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

Good job Martin ;)

comment:7 Changed 10 years ago by Martin Kou

Resolution: fixed
Status: assignedclosed

Fixed with [1501].

Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy