Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#1753 closed Bug (duplicate)

No context menu for text field properties

Reported by: mk@… Owned by:
Priority: Normal Milestone: FCKeditor 2.6
Component: UI : Context Menu Version: FCKeditor 2.5.1
Keywords: Confirmed FireFox Cc:

Description

If you have a text field in a form you can use the context menu to change the text field properties. In version 2.5.1 the context menu has no entry "Text Field Properties". This bug is for firefox ONLY (tested on version 2.0.0.11) - it works on IE Version 6 and 7.

Change History (6)

comment:1 Changed 11 years ago by Alfonso Martínez de Lizarrondo

According to #1779 this affects all form elements.

The problem seems to be the

FCKListsLib.StyleObjectElements[ range.startContainer.childNodes[ range.startOffset ].nodeName.toLowerCase() ] 

check in FCKSelection.GetType, the form elements aren't included in that list, I guess that the solution would be to add all of them there.

comment:2 Changed 11 years ago by Wojciech Olchawa

Keywords: Confirmed added
Priority: HighNormal

comment:3 Changed 11 years ago by Wojciech Olchawa

Keywords: FF added

comment:4 Changed 11 years ago by Alfonso Martínez de Lizarrondo

It looks that it's the same that #1682

comment:5 Changed 11 years ago by Wojciech Olchawa

Resolution: duplicate
Status: newclosed

DUP of #703

comment:6 Changed 11 years ago by Martin Kou

Milestone: FCKeditor 2.6

The patch in #1682 fixes this ticket as well.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy