Opened 12 years ago

Closed 11 years ago

Last modified 9 years ago

#703 closed Bug (wontfix)

FF: No context menu when right clicking a select component

Reported by: cunha17@… Owned by: Martin Kou
Priority: Normal Milestone: FCKeditor 2.6
Component: UI : Context Menu Version: FCKeditor 2.5.1
Keywords: SF Confirmed FireFox CantFix Cc: franp@…, voskat@…

Description

Linux FC4 Firefox 1.0.7 FCK 2.2, 2.1.1

When right clicking on a "select" component, no context menu appear.

Sometimes it's possible to left click on a "select" component and then right click on an empty editor space to get the context menu to appear. But this should not be a regular behaviour, does it?

Anyway, I propose a "properties" button on the toolbar, so we may select any component with the left button and then click on the "properties" toolbar button.

Regards,

Cristiano da Cunha Duarte


Moved from SF:
http://sourceforge.net/tracker/index.php?func=detail&aid=1438131&group_id=75348&atid=543653

Attachments (2)

contextMenuFix.zip (6.4 KB) - added by voskat 9 years ago.
This plugin fixes the context menu problem with checkboxes, radio buttons and select boxes in Firefox. This is version 1.2.1, which has been more thoroughly tested. Thanks to Gerrit Volkenborn!
contextMenuFix 1.2.2.zip (6.4 KB) - added by voskat 9 years ago.
This plugin fixes the context menu problem with checkboxes, radio buttons and select boxes in Firefox. This is version 1.2.2, which resolves a few minor niggles.

Download all attachments as: .zip

Change History (19)

comment:1 Changed 12 years ago by Martin Kou

Reporter: changed from Martin Kou to cunha17@…

comment:2 Changed 12 years ago by Martin Kou

This seams to be a Firefox limitation. For now, just click in the select field and use the "Selection Field" button in the toolbar to edit its properties.


Moved from SF. Original poster: fredck

Forget about it : I forgot that I had disallowed javascripts to change context menu. Now works OK. Sorry for the mistake. Keep up the good work.


Moved from SF. Original poster: franp

Same here whit FF 1.5.0.6 and FCKe 2.31.

When right-clicking on a component, FCKe context menu appears a fraction of a second (maybe 20 miliseconds, just enough to be seen) and then is replaced by FF right-click menu. This basicaly renders FCKe useless (unable to resize a table ; unable to change an existing link, etc.).

Will try to reverse to FCKe 2.2.


Moved from SF. Original poster: franp

comment:3 Changed 11 years ago by Wojciech Olchawa

Component: GeneralUI : Context Menu
Keywords: Confirmed FF added
Summary: No context menu when right clicking a select componentFF: No context menu when right clicking a select component
Version: FCKeditor 2.5.1

#1753 has been marked as DUP.

Actually the bug appears in the latest version (2.5.1) as well

comment:4 Changed 11 years ago by Wojciech Olchawa

This bug is partially similar to #680

comment:5 Changed 11 years ago by Martin Kou

Owner: set to Martin Kou
Status: newassigned

comment:6 Changed 11 years ago by Martin Kou

There are some other form elements that do not have context menus. e.g. radio buttons and checkboxes.

comment:7 Changed 11 years ago by Martin Kou

Milestone: FCKeditor 2.6

The bug seems to be not fixable with JavaScript alone. I've done some investigations into the matter and found Midas to be blocking 'contextmenu' and 'click' events for radio buttons, checkboxes and select boxes.

We'll need to report this bug to the Mozilla developers.

comment:8 Changed 11 years ago by Martin Kou

Keywords: CantFix added

comment:9 Changed 11 years ago by Wojciech Olchawa

#1697 has been marked as DUP

comment:10 Changed 11 years ago by Martin Kou

comment:11 Changed 11 years ago by Frederico Caldeira Knabben

Resolution: wontfix
Status: assignedclosed

comment:12 Changed 10 years ago by Alfonso Martínez de Lizarrondo

#2541 and #2471 have been marked as dups

comment:13 Changed 10 years ago by Alfonso Martínez de Lizarrondo

I meant #2571

comment:14 Changed 10 years ago by voskat

Cc: voskat@… added

comment:15 Changed 10 years ago by voskat

All you have to do is hook up the plugin (as in config.js) and the fix.css file.

I suggest you evaluate the plugin and maybe incorporate it into the next release of the editor. It works great for me! :-)

comment:16 in reply to:  15 Changed 9 years ago by Gerrit Volkenborn

Replying to voskat:

All you have to do is hook up the plugin (as in config.js) and the fix.css file.

I suggest you evaluate the plugin and maybe incorporate it into the next release of the editor. It works great for me! :-)

Hi, I tried to hook it up just now, but I guess I did something wrong!?

I patched the fckeditor.js to include the plugin and added the new code (var fixProcessor = FCKDocumentProcessor.AppendNew() and so on), but now I get a script error when trying to add the new select box, in file contentMenuFix/select.html, line 55:

SelectField( 'txtName' ) ;

It seems this function cannot be found!?

Changed 9 years ago by voskat

Attachment: contextMenuFix.zip added

This plugin fixes the context menu problem with checkboxes, radio buttons and select boxes in Firefox. This is version 1.2.1, which has been more thoroughly tested. Thanks to Gerrit Volkenborn!

comment:17 Changed 9 years ago by Frederico Caldeira Knabben

Cc: Frederico Caldeira Knabben removed

#4453 has been marked as DUP.

Changed 9 years ago by voskat

Attachment: contextMenuFix 1.2.2.zip added

This plugin fixes the context menu problem with checkboxes, radio buttons and select boxes in Firefox. This is version 1.2.2, which resolves a few minor niggles.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy