Opened 12 years ago

Closed 8 years ago

#1737 closed Bug (invalid)

[IE] HTML style value disappears every time wiki page is re edited

Reported by: Rohan Owned by:
Priority: Must have (possibly next milestone) Milestone:
Component: Project : MediaWiki+FCKeditor Version: FCKeditor 2.5
Keywords: IE Cc:

Description

I installed the latest version of FCK editor available on the FCK editor media wiki project page. On my wiki, every time I try to edit 'style'(HTML) on wikitext- for example: style="background-color:red"-

Once I save changes- the background color changes to red.

If I try to re-edit the page, the style becomes style="" and the background color is re set to default. Everytime I try to change style- the same happens.

Kindly help! This is urgent(as am sure is every other ticket- but you get the point.. :-))!

Change History (9)

comment:1 Changed 12 years ago by Wojciech Olchawa

Keywords: Confirmed IE IE7 added; Mediawiki FCKeditor HTML style removed
Priority: HighNormal
Summary: HTML style value disappears every time wiki page is re editedIE,IE7:HTML style value disappears every time wiki page is re edited

Confirmed
IE : very strange thing happens. e.g.

<font style="background-color:red">red</font>

turns into :

<font size="+0">red</font> word

IE7 : as in the example provided by Rohan the background color disappears e.g.

<font style="">red</font>

In FF2 everything work fine.

comment:2 Changed 12 years ago by Wojciech Olchawa

Keywords: IE7 removed

comment:3 Changed 12 years ago by Wojciech Olchawa

#1814 has been marked as DUP

comment:4 Changed 12 years ago by epagien

Line: 589 of fckplugin.js

attStr += ' ' + sAttName + '="' + sAttValue.replace( '"', '&quot;' ) + '"' ;

Error reported around this line of fckplugin.js. Will take a look with ambition to create a fix.

comment:5 Changed 12 years ago by Wojciech Olchawa

Summary: IE,IE7:HTML style value disappears every time wiki page is re edited[IE] HTML style value disappears every time wiki page is re edited
Version: FCKeditor 2.5

#1947 has been marked as DUP

comment:6 Changed 11 years ago by Wiktor Walc

#2070 marked as dup. Partially fixed with [1850].

comment:7 Changed 10 years ago by Peter Koppstein

Priority: NormalHigh

Loss of "style" can easily be shown in other browsers as well. E.g. using Chrome and FF, the style element is lost in the following (using today's FCKeditor (2.5 SVN Build 22365)):

<ol>

<li>First level, first item</li> <li>First level, second item <ol style="background-color:pink">

<li>Second level, first item</li> <li>Second level, second item</li>

</ol> <li>First level, third item</li>

</ol>

I'm setting this to "High" priority as it is a serious and pervasive problem that does not seem to have garnered much attention recently.

Thanks.

comment:8 Changed 10 years ago by Christian

There is a hack in a comment on #2161 that stops stripping of style elements. Probably solves this.

comment:9 Changed 8 years ago by Jakub Ś

Resolution: invalid
Status: confirmedclosed

Since FCKeditor is no longer supported and was replaced with CKEditor, active development of the MediaWiki extension and support for it are also finished.

I’m closing this ticket as it is no longer valid.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy