Opened 9 years ago

Closed 9 years ago

#2024 closed Bug (fixed)

FCKDialog IE selection error when in source view

Reported by: James Owned by: Martin Kou
Priority: Must have (possibly next milestone) Milestone: FCKeditor 2.6
Component: UI : Dialogs Version: SVN (FCKeditor) - Retired
Keywords: Confirmed IE HasPatch Review+ Cc:

Description

When trying to display a dialog using the new FCKDialog while on IE while in source view an error occurs.

IE says "'selection' is null or not an object"

I managed to track this error down to /fckeditor/editor/_source/internals/fckdialog.js line 112.

I don't understand in internal workings of FCKEditor fully. I have managed to work out that it's due to it trying to access the Editor which isn't about while in source view.

Adding a check for the EditMode and using the EditingArea.Textarea to select the selection seems to fix the problem. I'm not 100% sure this is the correct fix so an FCKEditor core dev will have to read though the patch I've attached.

Attachments (2)

fckdialog_ie_selection_source_view.patch (2.2 KB) - added by James 9 years ago.
2024.patch (1.3 KB) - added by Martin Kou 9 years ago.

Download all attachments as: .zip

Change History (8)

Changed 9 years ago by James

comment:1 Changed 9 years ago by Martin Kou

Owner: set to Martin Kou
Status: newassigned

comment:2 Changed 9 years ago by Martin Kou

Keywords: Confirmed IE Review? added; dialogs ie selection removed

Hi letssurf,

Your observations and the general idea of your patch are correct. The patch can be further simplified though. I'm attaching a simplified patch for review.

comment:3 Changed 9 years ago by Martin Kou

Keywords: HasPatch added

Changed 9 years ago by Martin Kou

Attachment: 2024.patch added

comment:4 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:5 Changed 9 years ago by James

Works for me. Thanks guys :) very fast fix.

comment:6 Changed 9 years ago by Martin Kou

Resolution: fixed
Status: assignedclosed

Fixed with [1726].

Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy