Opened 10 years ago

Closed 10 years ago

#2836 closed Bug (fixed)

V3: Toolbar commands doesn't get disabled in 'source' mode

Reported by: Artur Formella Owned by: Frederico Caldeira Knabben
Priority: Must have (possibly next milestone) Milestone: CKEditor 3.0
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Confirmed Review+ Cc:

Description

Steps to reproduce: -Open sample.html?sample=replacebyclass -Click Source -Click Smile button

Result: JS Error and cancel button doesn't work.

this.document is null
http://localhost/edytor/CKEditor/trunk/_source/plugins/selection/plugin.js
Line 219

Attachments (6)

2836.patch (13.4 KB) - added by Artur Formella 10 years ago.
2836_2.patch (13.0 KB) - added by Artur Formella 10 years ago.
2836_3.patch (15.8 KB) - added by Artur Formella 10 years ago.
2836_4.patch (12.6 KB) - added by Frederico Caldeira Knabben 10 years ago.
2836_5.patch (12.1 KB) - added by Frederico Caldeira Knabben 10 years ago.
2836_6.patch (12.2 KB) - added by Frederico Caldeira Knabben 10 years ago.

Download all attachments as: .zip

Change History (22)

comment:1 Changed 10 years ago by Garry Yao

Summary: V3: Source mode and dialogsV3: Toolbar commands doesn't get disabled in 'source' mode

comment:2 Changed 10 years ago by Garry Yao

Keywords: Confirmed added

comment:3 Changed 10 years ago by Frederico Caldeira Knabben

#2968 has been marked as DUP

comment:4 Changed 10 years ago by Artur Formella

Keywords: Review? added

Changed 10 years ago by Artur Formella

Attachment: 2836.patch added

comment:5 Changed 10 years ago by Garry Yao

Keywords: Review+ added; Review? removed

Please also update the latest plugin with 'activeInModes'.

comment:6 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review+ removed

The changes in _source/plugins/toolbar/plugin.js are not related.

Changed 10 years ago by Artur Formella

Attachment: 2836_2.patch added

comment:7 Changed 10 years ago by Artur Formella

Keywords: Review? added; Review- removed
Owner: set to Artur Formella
Status: newassigned

comment:8 Changed 10 years ago by Artur Formella

Keywords: Review- added; Review? removed

I forgot about flash plugin...

Changed 10 years ago by Artur Formella

Attachment: 2836_3.patch added

comment:9 Changed 10 years ago by Artur Formella

Keywords: Review? added; Review- removed

Improved WSC and flash plugin.

I open new tickets for richcombo and panelbutton

comment:10 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed
Owner: changed from Artur Formella to Frederico Caldeira Knabben
Status: assignednew

Your approach is not wrong. As most of the commands are available in WYSIWYG only, we could simplify it a bit by assuming a default values for the "activeInModes" property (which I would prefer calling simply "modes", for shortnesses).

It also misses support for the combos and the panel buttons (#3060). It means that we need also changes to the skin files.

As most of these things have been coded by me recently, and due to the urgency we have for this ticket, I'm taking it over. I'll come with a patch as soon as #3021 gets committed, because it will bring lots of changes to the skins CSS and I would prefer to work on it after that.

Changed 10 years ago by Frederico Caldeira Knabben

Attachment: 2836_4.patch added

comment:11 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review? added; Review- removed
Status: newassigned

Changed 10 years ago by Frederico Caldeira Knabben

Attachment: 2836_5.patch added

comment:12 Changed 10 years ago by Frederico Caldeira Knabben

New patch, without the unrelated change to sample.html.

comment:13 Changed 10 years ago by Garry Yao

Keywords: Review- added; Review? removed
  1. RichCombo marked list item state is not reset on mode switch, reproduce by :
    1. Open the replace by code example page;
    2. Open a combo and select a item;
    3. Switch to 'source' mode and then switch back;
      • Actual Result: Still marked selection result from previous.
  2. BOM in front of file _source\plugins\richcombo\plugin.js
  3. Trunk content inside _source\plugins\undo\plugin.js has none related changes to undo system, which should be handled by other tickets.
  4. It's better if the incoming patch could take care of the new plug-ins, save and maximize.

Changed 10 years ago by Frederico Caldeira Knabben

Attachment: 2836_6.patch added

comment:14 in reply to:  13 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review? added; Review- removed

Replying to garry.yao:

  1. RichCombo marked list item state is not reset on mode switch, reproduce by :
    1. Open the replace by code example page;
    2. Open a combo and select a item;
    3. Switch to 'source' mode and then switch back;
      • Actual Result: Still marked selection result from previous.

This one is not related to this ticket and should not block it. Please open a new ticket for it.

  1. BOM in front of file _source\plugins\richcombo\plugin.js

Again, this is not to be checked. It's not a problem to have the BOM there.

  1. Trunk content inside _source\plugins\undo\plugin.js has none related changes to undo system, which should be handled by other tickets.

It's definitely related, as the undo/redo buttons don't get disabled in source mode without it.

  1. It's better if the incoming patch could take care of the new plug-ins, save and maximize.

I've included the "save" plugin in this new patch. The "maximize" plugin is not yet in the trunk.

comment:15 Changed 10 years ago by Garry Yao

Keywords: Review+ added; Review? removed

comment:16 Changed 10 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

Fixed with [3227].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy