Opened 10 years ago

Closed 10 years ago

#3516 closed Bug (fixed)

JS error in Find & Replace dialog

Reported by: Tobiasz Cudnik Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.0
Component: General Version:
Keywords: Confirmed Review+ IBM Cc:

Description

TC

  1. Use following content:
    <p>
    	^foo<br />
    </p>
    <p>
    	foo<br />
    </p>
    
  2. Hit find button 2 or more times
  3. Result:
    find.js (line 216)
    endNode is null
    [Break on this error] while ( endNode.type != CKEDITOR.NODE_TEXT )
    
  4. Stack trace
    updateFromDomRange()
    removeHighlight()
    find()
    onClick()
    listenerFirer()
    (?)()
    (?)()
    listenerFirer()
    (?)()
    (?)()
    

Reproduced using r3500 in FF3, IE8.

Attachments (1)

3516.patch (3.7 KB) - added by Garry Yao 10 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 10 years ago by Damian

Keywords: IBM added

comment:2 Changed 10 years ago by Garry Yao

Keywords: Pending added

I didn't got the error besides the symptom described in #3450, or is it random?

comment:3 Changed 10 years ago by Tobiasz Cudnik

It happens all the time in my case but whole thing is very weird. Specially L219: endNode = boundaryNodes.endNode; ...after which endNode becomes null, while boundaryNodes.endNode is not.

I can't reproduce it in Opera and Chrome. Although i can reproduce it on firebug-less FF, so that's not a debugger fault. It also happens in IE8.

Best way to reproduce it is just hitting Find, Find, Find.

Possible workaround would be securing loop conditions and assignments at L220-L222.

Can someone else please try to reproduce it ?

comment:4 Changed 10 years ago by Tobiasz Cudnik

Sorry for no line break, pasting mentioned line again:

endNode = boundaryNodes.endNode;

comment:5 Changed 10 years ago by Garry Yao

Keywords: Confirmed added
Owner: set to Garry Yao
Status: newassigned

Changed 10 years ago by Garry Yao

Attachment: 3516.patch added

comment:6 Changed 10 years ago by Garry Yao

Keywords: Review? added; Pending removed

Running minor fixings.

comment:7 Changed 10 years ago by Martin Kou

Keywords: Review+ added; Review? removed

comment:8 Changed 10 years ago by Garry Yao

Resolution: fixed
Status: assignedclosed

Fixed with [3517].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy