Opened 8 years ago

Closed 8 years ago

#4128 closed Bug (duplicate)

[IE] Image dialog has scrollbar in quirksmode

Reported by: Garry Yao Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.0
Component: UI : Dialogs Version:
Keywords: Confirmed Pending HasPatch Cc:

Description (last modified by Garry Yao)

Reproducing Environment

  • IE6/IE7 Windows XP SP2
  • Quirks Mode
  • http:// protocol( Works fine with file:// protocol )
  • No Cache
  • language: zh-cn

Attachments (1)

4128.patch (2.0 KB) - added by Garry Yao 8 years ago.

Download all attachments as: .zip

Change History (16)

comment:1 Changed 8 years ago by Garry Yao

Description: modified (diff)

comment:2 Changed 8 years ago by Garry Yao

Description: modified (diff)

Update the description since it's not a regression at all, the reason's been similar with #4122 where this time it seems the txtAlt input caused the penetration.

Changed 8 years ago by Garry Yao

Attachment: 4128.patch added

comment:3 Changed 8 years ago by Garry Yao

Keywords: Confirmed Review? added
Owner: set to Garry Yao
Status: newassigned

comment:4 Changed 8 years ago by Garry Yao

The culprit is not the txtAlt but the page vbox table(div.cke_dialog_page_contents > table ) been over rendered.

comment:5 Changed 8 years ago by Tobiasz Cudnik

I couldn't reproduce this issue neither on IE7 or IE8. Does it depends on some specific editor's content ?

comment:6 in reply to:  5 Changed 8 years ago by Frederico Caldeira Knabben

Replying to tobiasz.cudnik:

I couldn't reproduce this issue neither on IE7 or IE8. Does it depends on some specific editor's content ?

Yes:

  1. Load the following HTML:
<p><img alt="Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Maecenas feugiat consequat diam. Maecenas metus. Vivamus diam purus, cursus a, commodo non, facilisis vitae, nulla. Aenean dictum lacinia tortor" height="110" src="http://www.google.com/intl/en_ALL/images/logo.gif" width="276" /></p>
  1. Right click the image and open the image dialog.

comment:7 Changed 8 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed

I can reproduce it with the above tc in IE7 standards. The patch makes no difference at all.

comment:8 Changed 8 years ago by Frederico Caldeira Knabben

Couldn't we use the same solution we've used at #4122?

comment:9 in reply to:  8 Changed 8 years ago by Garry Yao

Keywords: Pending HasPatch added; Review- removed

Replying to fredck:

Couldn't we use the same solution we've used at #4122?

The ticket is not meant to talk about overflow when edit an image, please open a new ticket for the above tc.

comment:10 Changed 8 years ago by Garry Yao

There should be no special content required to reproduce this issue besides what listed in the environment section.

comment:11 Changed 8 years ago by Frederico Caldeira Knabben

We need more information to reproduce it at this point. WFM by just opening the dialog in IE7+Quirks with clean cache.

comment:12 Changed 8 years ago by Tobiasz Cudnik

Still can't reproduce any of those issues, including with posted TC. Checked both IE6 and 7. Maybe it's yet another language problem ?

comment:13 in reply to:  12 Changed 8 years ago by Frederico Caldeira Knabben

Replying to tobiasz.cudnik:

Maybe it's yet another language problem?

As said, my tests are always in English. So, I think that's not the case.

comment:14 Changed 8 years ago by Garry Yao

Description: modified (diff)

Originally I have it on English version also but now it seems to me only appeared with 'zh-cn' language file,sorry for misleading here.

comment:15 Changed 8 years ago by Frederico Caldeira Knabben

Resolution: duplicate
Status: assignedclosed

DUP of #3878

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy