Ticket #4275 (closed Bug: invalid)

Opened 5 years ago

Last modified 5 years ago

CKEditor's tool bar is chopped off in IE7/IE8,

Reported by: Senthil Owned by: tobiasz.cudnik
Priority: High Milestone: CKEditor 3.1
Component: General Version:
Keywords: Oracle Cc: Pranav Senthil

Description

Patch delivered for Ticket #4237 (CKEditor's ToolBar is chopped off in Safari browser 3.x) is still not fixing the reported problem. So creating a new ticket as developer has asked to do so. Attaching the screenshot and sample file to replicate the problem.

Attachments

config.js (839 bytes) - added by Senthil 5 years ago.
toolbar_chopped_off.jpg (144.7 KB) - added by Senthil 5 years ago.
replacebycode.2.html (3.0 KB) - added by Senthil 5 years ago.
replacebycode.html (3.0 KB) - added by Senthil 5 years ago.

Change History

Changed 5 years ago by Senthil

Changed 5 years ago by Senthil

Changed 5 years ago by Senthil

Changed 5 years ago by Senthil

comment:1 Changed 5 years ago by garry.yao

  • Keywords Confirmed added

It's enough to spread #4237's fix to all browsers to have this fixed.

comment:2 follow-up: ↓ 3 Changed 5 years ago by garry.yao

Beside the mentioned issue, we should also notice that the background of toolbar is incorrectly fixed with 'arrows', probably due to the sprites.

comment:3 in reply to: ↑ 2 Changed 5 years ago by garry.yao

Replying to garry.yao:

Beside the mentioned issue, we should also notice that the background of toolbar is incorrectly fixed with 'arrows', probably due to the sprites.

Ah, just see it's already been reported at #4276 as a separated issue.

comment:4 Changed 5 years ago by tobiasz.cudnik

  • Status changed from new to assigned
  • Owner set to tobiasz.cudnik

comment:5 Changed 5 years ago by tobiasz.cudnik

  • Keywords Confirmed removed
  • Status changed from assigned to closed
  • Resolution set to invalid

I'm sorry but this is not a bug. It's about wrong toolbar config usage (or at least it's behavior understanding).

Toolbar is supposed to be wrapped on item groups, not item separators. In attached config there are only 3 groups, where each contains couple of separators. Editor width is very narrow and it should be wide at least as longest toolbar item group.

Browsers handle this situation in different ways, that's why IE just keeps it without break (which is correct) but they are out of viewport. FF forces to wrap them, but this results in garbaged layout (like visible sprites reported as #4276 but also as incorrect toolbar background, which shouldn't be an image).

This issue is something different than #4237, as problem there was wrapping of item groups.

If you change those "-" separators to groups, all will work fine. Here is the code.

config.toolbar =
[
	['Source','Image','Maximize','Preview','Print'], ['Cut','Copy','Paste'], ['Undo','Redo'], ['Find','Replace'], ['HorizontalRule','Table','imageUPLOAD','Link','Unlink','SpecialChar'],
	['Format','Font','FontSize'], ['Bold','Italic','Underline','Strike'],
	['JustifyLeft','JustifyCenter','JustifyRight','JustifyBlock'], ['NumberedList','BulletedList','Outdent','Indent'], ['TextColor','BGColor']
];

comment:6 Changed 5 years ago by garry.yao

I see the same reason with Tobias, though this might not be a good user experience at the moment. Ideally editor width should dominate everything and toolbar group should be smart enough to adapt to it( e.g. cropp off extra items ) while this is out the scope of this ticket.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy