Opened 7 years ago

Closed 4 years ago

#5722 closed Bug (wontfix)

[IE7] Paste into content RTL editor appears scrollbar

Reported by: Garry Yao Owned by:
Priority: Normal Milestone:
Component: General Version: 3.4.1
Keywords: IE Cc:

Description

#5667 is still seen on IE6/7.

Attachments (3)

5722.patch (526 bytes) - added by Sa'ar Zac Elias 7 years ago.
5722_2.patch (1.1 KB) - added by Sa'ar Zac Elias 7 years ago.
5722_3.patch (815 bytes) - added by Sa'ar Zac Elias 7 years ago.

Download all attachments as: .zip

Change History (18)

comment:1 Changed 7 years ago by Garry Yao

Perhaps this would result in a wonfix as right:-1000 is not recognized in a RTL container in IE6/7.

comment:2 Changed 7 years ago by Garry Yao

Keywords: Discussion added

Any brilliant mind here to properly hide the paste bin in this case?

comment:3 Changed 7 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.3CKEditor 3.4

comment:4 Changed 7 years ago by Sa'ar Zac Elias

Keywords: HasPatch added; Discussion removed

Using position: fixed resolves the problem.

Changed 7 years ago by Sa'ar Zac Elias

Attachment: 5722.patch added

comment:5 Changed 7 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.4CKEditor 3.5

comment:6 Changed 7 years ago by Sa'ar Zac Elias

Owner: set to Sa'ar Zac Elias
Status: confirmedassigned

Changed 7 years ago by Sa'ar Zac Elias

Attachment: 5722_2.patch added

comment:7 Changed 7 years ago by Sa'ar Zac Elias

Status: assignedreview

Since this the same bug also occurs in IE6, position:fixed would not work. So instead, just like in #5565, the pastebin is hidden to the top.

comment:8 Changed 7 years ago by Tobiasz Cudnik

Status: reviewreview_failed

Wouldn't it be better to target this fix only to affected browsers ? Code to be removed looks like a good one, let's not loose it.

comment:9 Changed 7 years ago by Sa'ar Zac Elias

Status: review_failedreview

Changed 7 years ago by Sa'ar Zac Elias

Attachment: 5722_3.patch added

comment:10 Changed 7 years ago by Frederico Caldeira Knabben

Status: reviewreview_passed
Version: SVN (CKEditor) - OLD3.4.1 (SVN - trunk)

comment:11 Changed 7 years ago by Frederico Caldeira Knabben

Status: review_passedreview_failed

Sorry... after patch the browser scrolls up and down on paste.

comment:12 Changed 7 years ago by Sa'ar Zac Elias

Owner: Sa'ar Zac Elias deleted
Status: review_failednew

I don't have any other solution for that.. Hopefully someone else has.

comment:13 Changed 7 years ago by Frederico Caldeira Knabben

Milestone: CKEditor 3.4.1
Status: newconfirmed

As this issue impact on a reduced number of users (IE6/7+RTL) and it doesn't have a critical impact (just the scrollbar quick flashing), I'm untargetting it, so we can deal with it later.

comment:14 Changed 7 years ago by Frederico Caldeira Knabben

Keywords: HasPatch removed

comment:15 Changed 4 years ago by Piotrek Koszuliński

Resolution: wontfix
Status: confirmedclosed

Cannot reproduce on IE8 and we do not support IE7 any more.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy