Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#6013 closed Bug (worksforme)

IE[6-9] + FF[10-11]: Focus not in input field after mouse click over "empty" content area

Reported by: tkrah Owned by:
Priority: Normal Milestone:
Component: General Version: 3.6.2
Keywords: IE FF Cc:

Description

Using CKEditor 3.2.1 (3.3.1 has this too) with IE6 does have a focus problem. Using Tab to get into the "edit" box does work. Clicking in the "first" line does work too - in both cases you can do some input.

But if you click anywhere in the content box but the first line (line where there is no text yet) it "seems" as the box got focus, but if you want to write something, nothing happen. You have to click again and after that it works.

Change History (9)

comment:1 Changed 9 years ago by tkrah

Even better this can be seen (in IE8 too) if you use contextmenu plugin. Right-click at the first line and you can click on "insert" - place the cursor somewhere else where there is no text yet but in the content area - the insert entry is disabled, you can't inser anything.

comment:2 Changed 9 years ago by tkrah

Summary: IE6: Focus not in input field after mouse click over "empty" content areaIE[6-8]: Focus not in input field after mouse click over "empty" content area

comment:3 Changed 8 years ago by Jakub Ś

Keywords: IE added
Status: newconfirmed
Summary: IE[6-8]: Focus not in input field after mouse click over "empty" content areaIE[6-9]: Focus not in input field after mouse click over "empty" content area
Version: 3.3.13.0

I was not able to reproduce the first TC but the second one:

Even better this can be seen (in IE8 too) if you use contextmenu plugin. Right-click at the >first line and you can click on "paste" - place the cursor somewhere else where there is >no text yet but in the content area - the “paste” entry is disabled, you can't insert >anything.

is easily reproducible in all versions of IE.

Any way those two TC's concern - small clickable\focusable area in IE browsers.

I have also found other tickets concerning this issue: #3832 #3990 #4591. the problem is that they are all closed as duplicates of #1659 which is set to fixed but...

The issue is still reproducible in all versions of IE.

comment:4 Changed 8 years ago by Jakub Ś

Other related tickets (duplicates) #6359, #5538, #7932.

comment:5 Changed 8 years ago by tkrah

Did a retest with 3.6.2. Issue with focus and first line is resolved, i can click everywhere and editor gets focus.

Second issue with context menu is the same. In IE6 right click in a "empty" row the menu is show but paste is disabled. Right click at a row where there is already some text or the first row, context menu paste is enabled.

In FF10 content menu right click in empty row the menu is is shown and disappears immediately. Right click in a row with some text, menu is there and paste is active.

comment:6 Changed 8 years ago by Jakub Ś

I did a quick test and it seems that patch from #7932 has fixed this issue.

comment:7 Changed 8 years ago by Frederico Caldeira Knabben

Resolution: worksforme
Status: confirmedclosed

comment:8 Changed 8 years ago by tkrah

Keywords: FF added
Summary: IE[6-9]: Focus not in input field after mouse click over "empty" content areaIE[6-9] + FF[10-11]: Focus not in input field after mouse click over "empty" content area
Version: 3.03.6.2

Ähh - its not working. Go to the official demo page and choose custom toolbar. No right click at area (FF 11 tested) on the first editor. Menu is shown but only sometimes it does "stay". Most of the time - click a few times right - its immediately closed again. Do not click at the first line where there is content, there it does indeed work - choose some space where there is/was no content yet.

comment:9 Changed 8 years ago by Jakub Ś

Ähh - its not working. Go to the official demo page and choose custom toolbar

@tkrah you have to apply the patch from #7932 to see it working or check the nightly version.

Demo shows only latest stable version. The latest trunk version can found in http://nightly.ckeditor.com/demo

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy