Opened 5 years ago

Closed 4 years ago

#6908 closed Bug (fixed)

Color of link can not be changed anymore after link text was made some format

Reported by: satya Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.6.2
Component: Core : Styles Version: 3.0
Keywords: IBM Cc: damo, joek, james, c

Description

To reproduce the defect:

  1. Open a CK Editor sample and insert a link in CKEditor
  1. It display in the editor body with underline and blue color.
  1. Select the link and select some text color(red) and see that the text color in the the link changes to Red.
  1. Select the link, select some font type or front size and see that the font size/type applied to the text in the link.
  1. Select the link again and select a different text color(brown).

Expected result:

Color of the text in the link changes to brown.

Actual result:

Color of the link changes to blue and no matter how many different text colors you applied after the color of the text in the link can not be changed anymore, it's blue color always.

Attachments (1)

6908.patch (759 bytes) - added by garry.yao 5 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 5 years ago by krst

  • Status changed from new to confirmed
  • Version set to 3.2

Changed 5 years ago by garry.yao

comment:2 Changed 5 years ago by garry.yao

  • Owner set to garry.yao
  • Status changed from confirmed to review

comment:3 follow-up: Changed 4 years ago by fredck

  • Cc james c added; james c removed
  • Status changed from review to pending

I'm not able to reproduce it with FF4. Can you confirm it?

comment:4 in reply to: ↑ 3 Changed 4 years ago by satya

Replying to fredck:

I'm not able to reproduce it with FF4. Can you confirm it?

Using nightly build, i could reproduce it FF4 & in all other browsers. colour of the link remains blue no matter how many different colors you apply.

comment:5 Changed 4 years ago by j.swiderski

  • Status changed from pending to confirmed
  • Version changed from 3.2 to 3.0

This issue was duplicated and confirmed in #7609.

Pasting the description of this bug as it might be helpfull:

FF and IE Go to CKEditor demo. Select the "fairy tale" hyperlink in the first line. Apply bold. Apply a color. The color does not get updated.

comment:6 Changed 4 years ago by garry.yao

Ticket tc added with [7145].

comment:7 Changed 4 years ago by garry.yao

  • Status changed from confirmed to review

comment:8 Changed 4 years ago by Saare

  • Status changed from review to review_passed

comment:9 Changed 4 years ago by garry.yao

  • Component changed from General to Core : Styles
  • Milestone set to CKEditor 3.6.2
  • Resolution set to fixed
  • Status changed from review_passed to closed

Ticket Test: view source.

Fixed with [7198].

Note: See TracTickets for help on using tickets.
© 2003 – 2015 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy