Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#7316 closed Bug (fixed)

[FF] Click on paste button create wrong linebreak

Reported by: Garry Yao Owned by: Garry Yao
Priority: Must have (possibly next milestone) Milestone: CKEditor 3.5.3
Component: Core : Pasting Version: 3.5.2
Keywords: Firefox IBM Cc: satya_minnekanti@…

Description

  1. Place cursor among text;
  2. Click on 'Paste' or 'Paste from Word' button;
  • Actual Result: Line break inserted at the position.

Attachments (2)

7316.patch (1.6 KB) - added by Garry Yao 10 years ago.
7316_2.patch (1008 bytes) - added by Garry Yao 10 years ago.

Download all attachments as: .zip

Change History (17)

Changed 10 years ago by Garry Yao

Attachment: 7316.patch added

comment:1 Changed 10 years ago by Garry Yao

Owner: set to Garry Yao
Status: newreview

Regression of [6373], where pastebin was affected by bogus br.

comment:2 Changed 10 years ago by Satya Minnekanti

Cc: satya_minnekanti@… added

comment:3 Changed 10 years ago by Sa'ar Zac Elias

#7331 is a dup.

comment:4 Changed 10 years ago by Wiktor Walc

Keywords: IBM added
Milestone: CKEditor 3.5.3

comment:5 Changed 10 years ago by Frederico Caldeira Knabben

Status: reviewreview_failed
  • The new "beforeSelectionChange" event is not needed. It's enough to listen to "selectionChange" with higher priority, canceling the event.
  • The removeListener() call is missing the listener function to be removed.

Changed 10 years ago by Garry Yao

Attachment: 7316_2.patch added

comment:6 Changed 10 years ago by Garry Yao

Status: review_failedreview

comment:7 Changed 10 years ago by Sa'ar Zac Elias

Status: reviewreview_passed

comment:8 Changed 10 years ago by Garry Yao

Resolution: fixed
Status: review_passedclosed

Fixed with [6556].

comment:9 Changed 10 years ago by James Cunningham

This is still reproducible on the latest nightly build on FF 3.6.15 and should be reopened.

comment:10 Changed 10 years ago by James Cunningham

This issue was not fixed as I can reproduce it on FF 3.6.6, 3.6.8 and 3.6.15. I would like this ticket to be reopened and this defect to be fixed. Thanks.

comment:11 Changed 10 years ago by Wiktor Walc

I have just tried to reproduce it in the trunk and on the nightly demo page and it works for me. Could you please check it again? Please make sure you have cleared browser's cache.

Note that I did manage to reproduce it on Rev 6555 samples but in recent revisions like Rev 6593 samples it works fine.

comment:12 Changed 10 years ago by James Cunningham

Sorry I failed to mention earlier that you must click ok on the Paste dialog to reproduce the defect outlined in the test case.

comment:13 Changed 10 years ago by Wiktor Walc

Please use FF 3.6.15 and open the following sample: Rev 6593 samples

  1. Select "some" (third word), press Ctrl+C
  2. Click between "You" and "are": "You |are"
  3. Press the "Paste" button
  4. In the "Paste" dialog press "Ctrl + V" (the cursor is blinking straight after "some", in the same line)
  5. Press "Ok" button
  6. The result is correct on my side:
    This is some <strong>sample text</strong>. You someare using (...)
    

Is it the same way how you reproduce it?

comment:14 Changed 10 years ago by James Cunningham

No I am reproducing it a different way.

  1. Open Rev 6593 samples in FF 3.6.15
  1. Click between "You" and "are": "You |are"
  1. Open the Paste dialog.
  1. Leave the paste dialog empty & click ok.

Result: Line break inserted between "You" and "are".

comment:15 Changed 10 years ago by Wiktor Walc

Confirmed and reported in #7368.

Note: See TracTickets for help on using tickets.
© 2003 – 2020 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy