Opened 7 years ago

Closed 7 years ago

#7358 closed Bug (fixed)

safari: we can't come out of Numbered/Bulleted list when some formatting is applied to text in list item

Reported by: Satya Minnekanti Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.5.3
Component: General Version: 3.5.3
Keywords: WebKit IBM Cc: Damian, Teresa Monahan, James Cunningham

Description

To reproduce the defect:

  1. Open Ajax sample, type some text, select it and apply some formatting to it ( for ex: bold).
  1. Select the text and click on Insert/Remove Numbered list button.
  1. See that a Numbered list starts with the select text as it's first list item.
  1. Keep cursor at end of the list item and press Enter twice.

Expected Result:

Cursor comes out of Numbered list and a new empty paragraph starts after Numbered list.

Actual Result:

Cursor will not comes out of Numbered list no matter how many times we press Enter. every time we press Enter it is creating a new empty list item.

Same issue happens with Bulleted list

Attachments (2)

7358.patch (1.7 KB) - added by Garry Yao 7 years ago.
7358_2.patch (1.7 KB) - added by Garry Yao 7 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 7 years ago by Jakub Ś

Status: newconfirmed

Occurs in Safari since revision version [6461]

comment:2 Changed 7 years ago by Wiktor Walc

Milestone: CKEditor 3.5.3

comment:3 Changed 7 years ago by Sa'ar Zac Elias

Keywords: WebKit added; IBM removed

comment:4 Changed 7 years ago by Sa'ar Zac Elias

Keywords: IBM added

comment:5 Changed 7 years ago by Sa'ar Zac Elias

Owner: set to Sa'ar Zac Elias
Status: confirmedassigned

Changed 7 years ago by Garry Yao

Attachment: 7358.patch added

comment:6 Changed 7 years ago by Garry Yao

Owner: changed from Sa'ar Zac Elias to Garry Yao
Status: assignedreview

comment:7 Changed 7 years ago by Sa'ar Zac Elias

Status: reviewreview_failed
  • Type some text, hit CTRL+A, click bold.
  • Click on list icon.
  • Put cursor at the end of the item.
  • Hit ENTER, click increase indent.
  • Type some text.
  • Hit ENTER twice.
  • Type sone text.

Expected: text in the last item should be bold. Actual: text missing the bolden style.

Changed 7 years ago by Garry Yao

Attachment: 7358_2.patch added

comment:8 Changed 7 years ago by Garry Yao

Status: review_failedreview

You've just caught a small glitch, now use "!CKEDITOR.tools.trim( node.getHtml() )" for empty text container judgment.

comment:9 Changed 7 years ago by Garry Yao

Resolution: fixed
Status: reviewclosed

As a tiny issue, I've fixed with [6618] to not defer the release.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy