Opened 9 years ago

Closed 9 years ago

#7359 closed Bug (fixed)

Safari : Paragraph formats not applied to list items properly

Reported by: Satya Minnekanti Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 3.5.3
Component: General Version: 3.5.3
Keywords: IBM Webkit Cc: Damian, James Cunningham, Teresa Monahan

Description

To reproduce the defect:

Scenario 1:

  1. Open Ajax Sample, click on Insert/Remove Numbered list button.
  1. See that Empty Numbered list starts.
  1. Open Paragraph format drop down list and click on Heading 1 option.

Expected Result:

h1 tag is applied to list item and when we start typing the text, it should be in Heading 1 format.

Actual Result:

A   with h1 is created inside list item and when we start typing the text, it is in normal format.

Scenario 2:

  1. Open Ajax Sample, click on Insert/Remove Numbered list button.
  1. See that Empty Numbered list starts.
  1. Enter some text in first list item, open Paragraph format drop down list and click on Heading 1 option.

Expected Result:

Existing text in the list should be converted to Heading 1 format and when we start typing the text, it should be in Heading 1 format.

Actual Result:

Existing text in the list is converted to Heading 1 format,cursor goes to a different line in same list item & when we start typing the text, it is in normal format.

Attachments (1)

7359.patch (1.4 KB) - added by Garry Yao 9 years ago.

Download all attachments as: .zip

Change History (11)

comment:3 Changed 9 years ago by Jakub Ś

I have also found that Scenario 2 is applicable for all IE browsers since CKEditor version 3.5.1

comment:4 Changed 9 years ago by Jakub Ś

I have removed previous comments since they had incorrect revision number. Sorry for that.

Problem started to occur in Webkit (Safari and Chrome) since revision version [6461]

comment:5 Changed 9 years ago by Jakub Ś

Status: newconfirmed

comment:6 Changed 9 years ago by Jakub Ś

Keywords: Webkit added

comment:7 Changed 9 years ago by Wiktor Walc

Milestone: CKEditor 3.5.3

Changed 9 years ago by Garry Yao

Attachment: 7359.patch added

comment:8 Changed 9 years ago by Garry Yao

Owner: set to Garry Yao
Status: confirmedreview

comment:9 Changed 9 years ago by Jakub Ś

Seems to work now in all browsers.

comment:10 Changed 9 years ago by Jakub Ś

I have tested Garry's patch and it works in all browsers.

comment:11 Changed 9 years ago by Sa'ar Zac Elias

Status: reviewreview_passed

comment:12 Changed 9 years ago by Garry Yao

Resolution: fixed
Status: review_passedclosed

Fixed with [6617].

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy