Opened 4 years ago

Closed 2 years ago

#8003 closed Bug (wontfix)

CKPackager: issue with leaking variables

Reported by: wwalc Owned by:
Priority: Normal Milestone:
Component: Project : CKPackager Version:
Keywords: Cc:

Description

Just to not lose it, #8000 revealed a problem with CKPackager. I'm leaving a ticket to investigate it.

Attachments (1)

8003_TC.patch (630 bytes) - added by garry.yao 4 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 4 years ago by j.swiderski

  • Status changed from new to confirmed

comment:2 Changed 4 years ago by fredck

  • Status changed from confirmed to pending

Please add a simple TC here.

comment:3 Changed 4 years ago by garry.yao

  • Milestone set to CKEditor 3.6.2
  • Status changed from pending to confirmed

Changed 4 years ago by garry.yao

comment:4 Changed 4 years ago by garry.yao

After a quick check the fixes of this issue requires huge change to the current packager, which currently does a single pass on both parsing and outputting, while detecting duplicate identifiers requires a pre-process of building symbol tree.

Right now we can workaround this issue by avoid using short variable names, while obviously it's not bulletproof.

comment:5 Changed 4 years ago by fredck

  • Milestone CKEditor 3.6.2 deleted

comment:6 Changed 2 years ago by Reinmar

  • Resolution set to wontfix
  • Status changed from confirmed to closed

Since we use Google Closure Compiler it's no longer an issue that we need to fix.

Note: See TracTickets for help on using tickets.
© 2003 – 2015 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy