Opened 10 years ago

Closed 9 years ago

#8056 closed Bug (duplicate)

[IE] Cursor jumps to the top when clicking at the bottom of the editing area

Reported by: Dinu Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: IE Cc:

Description (last modified by Wiktor Walc)

Init content with:

<table border="1" cellpadding="1" cellspacing="1" style="width: 100%; height: 1000px;">
	<tbody>
		<tr>
			<td>
				&nbsp;</td>
			<td>
				&nbsp;</td>
		</tr>
		<tr>
			<td>
				&nbsp;</td>
			<td>
				&nbsp;</td>
		</tr>
		<tr>
			<td>
				&nbsp;</td>
			<td>
				&nbsp;</td>
		</tr>
	</tbody>
</table>
<p>
	&nbsp;</p>

Click on first cell then click in the last paragraph after the table. Page will scroll.

Note: click below the last paragraph, just a bit above the elements path.

Attachments (1)

autogrow.html (4.7 KB) - added by Dinu 10 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 10 years ago by Jakub Ś

Status: newpending

I think I'll be needing more information on this one because I was not able to reproduce it.

Here is what I did:
I have loaded the page with content you have provided.
Clicked inside first cell (autogrow triggered)
Scrolled down to the bottom of CKEditor
Clicked last paragraph

What have I missed in above steps? Also what OS and browser are you using and which CKEditor version does this issue concern?

comment:2 Changed 10 years ago by Jakub Ś

@dinu Any updates regarding this issue?

comment:3 Changed 10 years ago by Dinu

Yes, using HEAD and IE 9 (with 9,8,7 mode) on Win7.
Attaching autogrow.html just to be sure.
If you do this: open html, click on top left cell, then click on para below table, the whole page's scroll position will move from what it was before the second click.

Changed 10 years ago by Dinu

Attachment: autogrow.html added

comment:4 Changed 10 years ago by Wiktor Walc

Not sure if that's exactly the thing you are talking about, but I have noticed that using the sample you have provided in IE9 indeed cursor jumps for half a second into the first cell and then gets back into the right place.

To reproduce it, click below the last paragraph, just a bit above the elements path. It has nothing to do with autogrow though, because it can be reproduced in the replacebyclass sample as well.

comment:5 Changed 10 years ago by Dinu

I assumed it was because the autogrow flicker; my bad.

comment:6 Changed 10 years ago by Wiktor Walc

Keywords: IE added
Status: pendingconfirmed
Version: 3.0

No problem, thanks for the confirmation. It looks like it can be reproduced since 3.0 (the behaviour is changing a bit between various versions of the editor, but in IE9 the cursor jumps always to the top, at least for a while).

comment:7 Changed 10 years ago by Wiktor Walc

Description: modified (diff)
Summary: [IE] Autogrow intermediate resize and scrolling[IE] Cursor jumps to the top when clicking at the bottom of the editing area

comment:9 Changed 10 years ago by Wiktor Walc

Actually confirmed also in IE8.

comment:10 Changed 9 years ago by Garry Yao

Resolution: duplicate
Status: confirmedclosed

DUP of #8393.

Note: See TracTickets for help on using tickets.
© 2003 – 2021 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy