Ticket #8393 (closed Bug: fixed)

Opened 3 years ago

Last modified 2 years ago

ie with large content - after scrolling to the bottom of the content and clicking inside editor, jumps back to top of content

Reported by: michelechen Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.6.3
Component: Core : Selection Version: 3.0
Keywords: IE IBM HasPatch Cc: satya_minnekanti@…, michael@…, mattleff@…, ruud_vossen@…

Description

This is related to the following forum issue: http://cksource.com/forums/viewtopic.php?f=11&t=16840&hilit=ie7+scroll

I am still seeing the issue in the nightly build when using IE7: http://nightly.ckeditor.com/7288/_samples/replacebyclass.html

  • in the editor, go to source mode and paste a large amount of html text (see attached the sample file).
  • then go back to wysiwyg mode, and click inside the editor at the very beginning of the text
  • scroll all the way down to the bottom, locate the bottom arrow of the scroll, and click in the editor area directly to the left of it (it will be a pointer cursor instead of the text cursor).
  • see that it jumps back to the top of the editor.

Attachments

html for ie7 scroll issue.txt (136.9 KB) - added by michelechen 3 years ago.
8393.patch (5.7 KB) - added by garry.yao 2 years ago.
8510.jpeg (53.1 KB) - added by satya 2 years ago.

Change History

Changed 3 years ago by michelechen

comment:1 Changed 3 years ago by j.swiderski

  • Status changed from new to confirmed
  • Keywords IE added
  • Version changed from 3.6 to 3.0
  • Summary changed from ie7 with large content - after scrolling to the bottom of the content and clicking inside editor, jumps back to top of content to ie with large content - after scrolling to the bottom of the content and clicking inside editor, jumps back to top of content

To reproduce:

  1. Go to source mode and paste contents of the attached file.
  2. Switch back to WYSIWYG and click at the beginning of the text (^Samples of HTML codes)
  3. Scroll down using mouse wheel. You don't have to scroll all the way down. Just a couple of scrolls will do.
  4. Locate the bottom arrow of the scroll bar, and click in the editor content area directly to the left of it (IN IE7 and IE6 pointer will be a pointer cursor and in IE8 and IE9 it will be a text cursor).

Results:
IE6 and IE7
Till 3.0.1 - editor jumps up and focus in content area is lost
From 3.0.2 - editor jumps up and cursor is blinking at the top of content area.
IE8 and IE9
Till 3.3.1 - editor jumps up and cursor is blinking at the top of content area.
From 3.3.2 - editor jumps first up and than down to the place where mouse was clicked. Note that in IE9 it works very very slow, you have to wait good couple of seconds to se the issue (at least with the provided sample).

Last edited 2 years ago by j.swiderski (previous) (diff)

comment:2 Changed 3 years ago by j.swiderski

comment:3 Changed 2 years ago by j.swiderski

This issue was duplicated in #8510.

#8510 shows that text from demo page is enough to reproduce the isssue

comment:4 Changed 2 years ago by ikari

I can confirm this in Google Chrome 17 (and, AFAIR, all older versions) as well. In Firefox, I'm pretty sure this happened as well, but doesn't happen in FF8 anymore (at least now when I'm testing).

From my experience, clicking anywhere makes it jump to top of the viewport, but, what's more interesting, the caret remains where you clicked. It always happens when the editor didn't have focus before the click, and never happens if it did.

Seems extremely annoying.

comment:5 Changed 2 years ago by satya

  • Keywords IBM added
  • Cc satya_minnekanti@… added

comment:6 Changed 2 years ago by mjo

  • Cc michael@… added

This is an issue for me as well, using Firefox 8.0 with the CKEditor 3.6.2.

comment:7 Changed 2 years ago by garry.yao

#8056 has been marked as a DUP.

Changed 2 years ago by garry.yao

comment:8 Changed 2 years ago by garry.yao

It's turns out that the "focus grabber" hack we've used to for sometime could cause unwanted page scroll (caused by focus lost) , new patch come with a new approach to [4563] in IE as well as [5391] in FF.

comment:9 Changed 2 years ago by garry.yao

  • Status changed from confirmed to review
  • Owner set to garry.yao
  • Component changed from General to Core : Selection
  • Milestone set to CKEditor 3.6.3

comment:10 Changed 2 years ago by mjo

I'm willing to test this in FF, but I can't get the patch to apply. Are there any prerequisites for 8393.patch?

Last edited 2 years ago by mjo (previous) (diff)

comment:11 Changed 2 years ago by mattleff

  • Cc mattleff@… added

I can reproduce the issue in Chrome 16 and FF7.

comment:12 Changed 2 years ago by vosmanz

  • Cc ruud_vossen@… added

Is only [8393] needed to patch this problem? Or also [4563] and [5391]?

comment:13 Changed 2 years ago by mattleff

Any progress on this?

comment:14 Changed 2 years ago by j.swiderski

Scrolling up and down in IE9 was also mentioned in #8729

comment:15 Changed 2 years ago by j.swiderski

Other tickets that concern scrolling problems in IE: #8729, #8643, #5615

comment:16 Changed 2 years ago by j.swiderski

  • Keywords HasPatch added

comment:17 Changed 2 years ago by fredck

  • Status changed from review to assigned

This ticket is supposed to be fixed by #7932.

comment:18 Changed 2 years ago by garry.yao

  • Status changed from assigned to closed
  • Resolution set to fixed

comment:19 follow-up: ↓ 21 Changed 2 years ago by satya

It's not properly fixed. In IE7 when we click the mouse to the left of scrollbar, while the pointer is still the default arrow and not the I-Beam, focus goes out of editor body and we can't type in to editor. I have attached a screenshot to help identify the area.

Please re-open this ticket.

Changed 2 years ago by satya

comment:20 Changed 2 years ago by garry.yao

Considering the region u pointed to is related to the CSS margin for the body element, and can be safely controlled by your app's content style, e.g. with a smaller margin for the body element in content.css, otherwise it will be difficult for us to workaround this issue with the fix here. Can u check this as an option for you?

comment:21 in reply to: ↑ 19 Changed 2 years ago by fredck

Replying to satya:

It's not properly fixed. In IE7 when we click the mouse to the left of scrollbar, while the pointer is still the default arrow and not the I-Beam, focus goes out of editor body and we can't type in to editor. I have attached a screenshot to help identify the area.

Please re-open this ticket.

Due to the difference on the TC, I've opened #8835 for it.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy