Opened 8 years ago

Closed 6 years ago

#8996 closed Bug (fixed)

Pasting into styled content results in multiple style tags instead of just one

Reported by: Teresa Monahan Owned by:
Priority: Normal Milestone:
Component: General Version: 3.5
Keywords: IBM Cc: Damian, Satya Minnekanti

Description

To reproduce:

  • Open the replacebyclass sample and place the cursor between the words 'sample' and 'text'. Note that these words have a bold styling applied.
  • Open the 'Paste as plain text' dialog and type some content.
  • Click Ok.
  • Switch to source mode to see the HTML content.

Problem: The bold styling is split into 3 different strong tags. It should be merged into one single tag.

Actual Result:

<strong>sample </strong><strong>pasted text </strong><strong>text</strong>

Expected Result:

<strong>sample pasted text text</strong>

This issue is also mentioned in ticket #8908.

It also happens if styled text is pasted into styled content in the editor using Ctrl+V e.g. select the word text in the above sample, place the cursor inside the word sample and use Ctrl+V. There will now be 3 different strong tags for this content.

Change History (3)

comment:1 Changed 8 years ago by Jakub Ś

Status: newconfirmed
Version: 3.6.4 (SVN - trunk)3.5

This particular TC has been reproducible from CKEditor 3.5

<strong>sa</strong><strong>test</strong><strong>mple text</strong>

Before this version (till 3.4.3) the result was:

<strong>sa</strong>test<strong>mple text</strong>

comment:2 Changed 6 years ago by Teresa Monahan

This appears to be fixed in CKEditor 4

comment:3 Changed 6 years ago by Jakub Ś

Resolution: fixed
Status: confirmedclosed

I can confirm that this seems to be working in every browser.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy