Opened 7 years ago

Closed 6 years ago

#9138 closed Bug (wontfix)

[IE8 Quirks] Placeholder plugin

Reported by: Robert Owned by:
Priority: Normal Milestone:
Component: General Version: 3.5.3
Keywords: IE8 Cc:

Description

Found in IE8 Quirks - works fine in standard mode

  1. Open placeholder.html sample
  2. Select some text inside placeholder, e.g. 'sample' - it is possible to select only couple of letters.
  3. Click on Create placeholder toolbar button
  4. Type something (e.g. '111') and click 'Ok'

Result: new placeholder is created at the beginning of the line:

<p>
	[[111]]This is a [[sample placeholder]]. You are using <a href="http://ckeditor.com/">CKEditor</a>.</p>
  1. Repeat steps 3-4 but use '222' for the placeholder

Result: First bracket from first placeholder is cut off, '222' is not present anywhere.

<p>
	[111]]This is a [[sample placeholder]]. You are using <a href="http://ckeditor.com/">CKEditor</a>.</p>

Reproducible at least from 3.6

Change History (3)

comment:1 Changed 7 years ago by Jakub Ś

Keywords: IE8 added; placeholder removed
Status: newconfirmed
Version: 3.5.3

Pasting comment from #8989 which describes this problem:

It is possible to insert two placeholders in a row only if you haven’t clicked inside editing area after inserting first placeholder (click toolbar button, insert placeholder, click toolbar button again and insert another placeholder). If you have clicked inside editing area after inserting the first placeholder, the second place holder was not inserted and it was destroying the first one (removing [).

This TC has been reproducible in IE8 Quirks from CKE 3.5.3 rev. [6459]

comment:2 Changed 7 years ago by Jakub Ś

Please also have a look at 8989 and #8990. They all seem to be related.

comment:3 Changed 6 years ago by Piotrek Koszuliński

Resolution: wontfix
Status: confirmedclosed

Placeholder plugin is not support on IE Quirks any more, because it uses widgets which don't (and won't) work on in QM.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy