Opened 6 years ago

Closed 6 years ago

#9532 closed Bug (fixed)

[IE9] Apply anchor cause editor focus lose

Reported by: Garry Yao Owned by: Garry Yao
Priority: Normal Milestone: CKEditor 4.0
Component: Core : Focus Version: 4.0
Keywords: IE Cc:

Description (last modified by Garry Yao)

  1. Open inlineall sample;
  2. Start a text selection within any editable region;
  3. Open an anchor dialog and apply the style;
  • Actual: Editor loses focus, toolbar hides

Change History (11)

comment:1 Changed 6 years ago by Garry Yao

Keywords: IE added
Status: newconfirmed

Works in both IE7/8.

comment:2 Changed 6 years ago by Garry Yao

Description: modified (diff)
Summary: [IE9] Apply anchor loose editor style[IE9] Apply anchor loose editor focus

comment:3 Changed 6 years ago by Garry Yao

Description: modified (diff)
Summary: [IE9] Apply anchor loose editor focus[IE9] Apply anchor cause editor focus lose

comment:4 Changed 6 years ago by Garry Yao

The reproduction of this bug is system speed dependent, it can be constantly reproduced on IE10 in Windows Preface though.

While another symptom of this bug can be constantly reproduced on any IE9/10:

  1. Open dialog to inserted anything, e.g. Link or Table;
  2. After focus has returned to the editable, click outside of the editable region to remove the focus;
  • Actual: Editor focus remain, even editable has lost focus, it wouldn't be possible to hide the floating toolbar.

comment:5 Changed 6 years ago by Garry Yao

It's regression of [7364] from v3, the change onto dialogui plugin, impose a focus request (onto the button), from within a click event stack, which causes IE to defer the processing (refocus of the button) until the dialog has closed.

comment:6 Changed 6 years ago by Garry Yao

Owner: set to Garry Yao
Status: confirmedreview

Opened t/9532 for review, the patch revert the imposed focus call when clicking dialog button, focus returning feature in #8699 is instead handled by the specific dialog field which opens new dialog.

comment:7 Changed 6 years ago by Piotrek Koszuliński

Status: reviewreview_failed

I force pushed rebased t/9532 with one additional commit fixing doc and minor issue in getColorFromDialog (JS error was thrown).

I couldn't reproduce issue mentioned in ticket description, but I was able to reproduce the one from comment:4. Unfortunately I'm still able to reproduce it on t/9532.

comment:8 Changed 6 years ago by Garry Yao

Status: review_failedreview

Ok, comment:4 TC is reproducible only on IE9, with Anchor dialog in fact, I pushed another commit to address the issue:

There's a range selecting call on a locked selection from the Anchor dialog, which will move focus around for couple of times, and the culprit is that focus is not fired synchronously in that case, which breaks the editor focus state.

comment:9 Changed 6 years ago by Piotrek Koszuliński

Status: reviewreview_passed

comment:11 Changed 6 years ago by Garry Yao

Resolution: fixed
Status: review_passedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy