Opened 8 years ago

Closed 8 years ago

#4378 closed Task (fixed)

V3 : Feature Alignment

Reported by: Garry Yao Owned by:
Priority: Normal Milestone: CKEditor 3.1
Component: General Version:
Keywords: Umbrella Confirmed Cc:

Description (last modified by Frederico Caldeira Knabben)

This is an umbrella ticket (Originate from alfonsoml's forum post).

It points to several to be completed tickets that compose the feature alignments (with V2 ) of CKEditor.

Full Page

#4067
Fullpage support

#4587
Implement fullpage support in preview plugin

#4588
Implement document properties plugin

Div Container

#2885
Implement the div container command.

Toolbar location Out & Shared toolbar

#4228
V3: Support for toolbar location "out" and toolbar sharing

Use default browser's context menu

#4343
Implement BrowserContextMenuOnCtrl

Email protection

#4340
Implement Email protection

Detect paste from word

#1427
Autodetect clipboard contents on Paste

Show table borders

#4341
Implement ShowBorders

Base Href

#3401
V3 - Implement baseHref functionality

Body Id and Class

#4342
Implement Body Id & Class

Inline CSS support

#4463
V3 : Inline CSS support

HtmlEncodeOutput

#4708
Missing configuration from pre-3.0: HtmlEncodeOutput

Table merging tools

#4574
V3: Table merging tools

Font/Background more colors

#3881
More Colors

Change History (9)

comment:1 Changed 8 years ago by Alfonso Martínez de Lizarrondo

This seems like a loop, because I just put it there linking to this wiki page http://dev.fckeditor.net/wiki/v3_status because most of the people won't ever find it.

But it's important to remember that there are several other features that are missing in 3.0 and aren't included in those tickets. Until there is feature compatibility with v2 lots of people can't upgrade, no matter how nice other new features might look like. So in a sense, working on other features could be seen as a waste of time.

There should be a clean upgrade path, you can't expect people to find out all the quirks by themselves and struggle to make it work like it used to.

comment:2 Changed 8 years ago by Frederico Caldeira Knabben

Description: modified (diff)
Keywords: Confirmed added
Milestone: CKEditor 3.1

comment:3 Changed 8 years ago by Frederico Caldeira Knabben

Description: modified (diff)

comment:4 Changed 8 years ago by Frederico Caldeira Knabben

Description: modified (diff)

comment:5 Changed 8 years ago by Garry Yao

Description: modified (diff)

comment:6 Changed 8 years ago by Frederico Caldeira Knabben

Description: modified (diff)

comment:7 Changed 8 years ago by Garry Yao

Description: modified (diff)

comment:8 Changed 8 years ago by Frederico Caldeira Knabben

Description: modified (diff)

comment:9 Changed 8 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy