Opened 6 years ago

Closed 6 years ago

#11712 closed Task (fixed)

[iOS][Android] Mobile research

Reported by: Piotr Jasiun Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: iOS Android Cc:

Description (last modified by Piotr Jasiun)

Check how CKEditor works on Chrome 33 on Android 4.4.2 and Safari (537.51.2) on iOS 7.1 (iPad).

Change History (7)

comment:1 Changed 6 years ago by Piotr Jasiun

Description: modified (diff)
Summary: Android researchMobile research

comment:2 Changed 6 years ago by Piotr Jasiun

In the t/11712 are samples with weinre scripts.

comment:3 Changed 6 years ago by Piotr Jasiun

Description: modified (diff)

comment:4 Changed 6 years ago by Piotr Jasiun

Keywords: iOS Android added
Summary: Mobile research[iOS][Android] Mobile research

comment:5 Changed 6 years ago by Piotr Jasiun

Both Android & iOS

  • no way to open context menu (Android: #10083),
  • drag & drop does not work (table resizer, widgets, dialogs) (#11722, iOS: #8313),
  • there are no tab key, alt, shift+enter etc. so some of the features are not available,
  • copy/cut buttons are not enabled (#10590, Android: #10107),
  • dialogs are in the wrong position if I use zoom and it is not possible to move them (Android: #10082, iOS: not draggable: #8313, wrong possition: #11721)
  • "Replace DIV with CKEditor" sample does not work (#8319)

Android

Tested on CKEditor 4.3.4, Chrome 33 on Android 4.4.2 on 7 inch Nexus 7 and 10 inch Nexus 10.

What surprisingly works good:

  • Selection: long press on the word and we can easily edit selection, it is convenient.
  • Toolbar zoom: when I want to press a toolbar button Android somehow recognize that there are a lot of buttons and show zoomed in that part of the toolbar with hovered button I presses at the first time. Then I need to press the correct button again. Seems to be weird at the beginning, but is very useful.
  • Magicline: then cursor is next to the position of the magicline it is shown and we can use it.

What is inconvenient:

  • Toolbar is usually out of the viewport on the Nexus 7,
  • we need to use zoom a lot on the Nexus 7,
  • editor is usable only in portrait orientation on the Nexus 7.

Bugs:

<ost of the bugs reported for the old native Android web browser is no longer valid in the newest Android with Chrome as a default browser. Bugs invalid in Android 4.4.2 and Chrome 33: #9736, #9997, #10069, #10070, #10074, #10084, #10108, ~10 valid bugs, most important:

  • dropdows work unstable (#11724),
  • mobile Chrome is not recognize as mobile (#11725),
  • CKEditor 4.2 'change' event not fired on Android (Chrome or Native) (#10926),
  • smiles (which work differently on Nexus 7 and Nexus 10) (#11726),
  • Android changes font size in the contenteditable area (#11728).

iOS

Tested with Safari (537.51.2) on iOS 7.1 (iPad).

What is inconvenient:

  • iOS creates context options when user select any content which allows user to cut, copy or format text; we have no control how it works what is the reason of many problems (#11734, #8309, #8318).

What surprisingly works good:

  • the first impression is good, editor seems to work more smoothly then on Android,
  • build in context commands works with CKEditor styles.

Bugs:

More then 40 reported bugs, most important:

  • page is scrolling then I apply bold, change fond size etc. (#11730),
  • dialogs move focus to the begging of the document (#11731),
  • it is not possible to open Image2 edit dialog (#11733),
  • build-in context commands does not work with ACF and undo (#11734),
  • after selection build in context commands may hide toolbar and it is not possible to hide it without loosing focus (#8309, #8318).

Summary:

Android makes worse first impression, everything is zooming in and out, sometimes jumping up and down when loading, but after a while you can used to this and you find out it useful. There are more features working surprisingly fine then bugs. It is already usable. Because of bugs I had to try multiple times before I succeeded to format text, use toolbar buttons instead of context menu or copy and paste instead of drag and drop, use dialog to resize image etc.. But the vast majority of the format operations were somehow available. The only single operation I was not able to do at all was widgets moving (both D&D and C&P does not work on widgets). After some bug fixing Chrome on Android might be fairly stable.

We should keep in mind that Android is fragmented. Even testing the same browser and system I met different problems (like smiles: #11726). Not only different browsers and OS version might be a reason of different problems but also different screen size and density, different vendors (Samsung liked to implement his own parts of the core code) or different keyboard (in fact it is possible to have "hover" on Android if you have arrows or touchpad). We should check how CKE works on the different OS version with the same version of Chrome.

iOS makes a good first impression but it is buggy. Some format operations were not available at all. Because of bugs it is hard and annoying to use the editor. It seems to need more time to fix everything, but most of the bugs seems to be fixable.

After spending some time with bugs it should be possible to make CKEditor stable on mobile, but it is hard to estimate how much time and work it would take. It depends to how many of these bugs are related to the way how contenteditable works on mobile and how flexible and configurable it is.

comment:6 Changed 6 years ago by Jakub Ś

Status: newconfirmed

comment:7 Changed 6 years ago by Piotr Jasiun

Resolution: fixed
Status: confirmedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy